Support » Plugin: WP Mingle » Sad state of affairs

  • I see the developer updated this plugin only a month ago and with WP 3.5.2 it still doesn’t work. I have looked at the developer as a talented person for some time, and I have hoped above hope that he would devote some time to this project.

    Now that he has, I’m thinking I was wrong about him. This is a sad state of affairs. Then when I go over to his website, the plugin available there is older than this one. What a mess.

    Then go the his forums.. Oops.. same person moderating there as is moderating the WP Symposium forums.. What’s really going on?

    I sure look forward to finding a decent alternative to BuddyPress.. But I guess that is going to be a while.. more..

    What’s this about anyway?

    Fatal error: Call-time pass-by-reference has been removed in XXXXXXXX\public_html\wp-content\plugins\mingle\classes\models\MnglBoardPost.php on line 19

    http://wordpress.org/plugins/mingle/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I heard someone is going to continue Mingle… maybe under a new name.

    And?

    I’ve ‘heard’ a lot of things. Would be nice.

    Hi

    That error is caused by running php5.4

    I used to have php5.3 on my server and mingle worked just fine. Then today I upgraded the php on my web server and got the above error.

    You’ll need to make a minor adjustment to two files to get wp mingle to work with 5.4 because of a depreciation.

    As most web servers are still running php5.3 I guess the developer may not have php5.4 running.

    The change is simle enough to do as the error above tells you which file and what line to change. it’s just a questions of deleting a & symbol.

    After you’ve done the models/MnglBoardPost.php you’ll get another error for a helpers/MinlBoardHelper file to do the same deletion again.

    After those two minor changes the mingles will be working again

    Hope it helps
    Kevin

    oshi

    (@thugzanime)

    Hey @kevin Heath, Thanks for the tip help 😀

    Thanks @kevin Heath. Do you know why that fixes it? I’m curious what switched in PHP 5.4 that makes this plugin work without that ampersand symbol.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sad state of affairs’ is closed to new replies.