• Resolved proteusbr


    I made a IAM permition using policies: AmazonS3FullAccess and CloudFrontFullAccess
    Made a S3 using not plubic and static web hosting enable
    Made a secound S3 defout configuration and public
    Made a Cloudfront origem in from de S3

    When I put only access Key, secret, bucket, region automatic and no CDN. I recive a error: Your AWS S3 settings are incorrect or the bucket does not exist. Please verify your settings and update them.

    If I put everything again, many times, the error random get out.

    When there is no error, if I save again, I get the same error.

    I have turn on debug. Where I can see the log?
    Do you have any sugestion?

Viewing 1 replies (of 1 total)
  • Plugin Author interfacelab


    This is the minimum IAM policy you need to have:

        "Version": "2012-10-17",
        "Statement": [
                "Effect": "Allow",
                "Action": [
                "Resource": [
                "Effect": "Allow",
                "Action": "s3:HeadBucket",
                "Resource": "*"

    Is your AmazonS3FullAccess tied to a specific bucket or resource?

    This is what I would do:

    – Create a new bucket (use default settings)
    – Create a new IAM user
    – Attach the above policy to the new user (replace YOURBUCKET in the policy with the name of the bucket you want to use).
    – Plug the new info into the media cloud plugin and see if you still get the error.

    If you still get the error, try the WP Offload S3 plugin and see if you still have problems. If you do, then there is something else going on. If not, there is an issue with Media Cloud, but I doubt it.

Viewing 1 replies (of 1 total)
  • The topic ‘S3 + Cloudfront Error’ is closed to new replies.