1. cyberetto
    Posted 3 years ago #

    I"ve just updated to the latest version (3.0.1), and it said to check these settings:

    Dropbox authentication must be done again
    SugarSync authentication must be done again
    S3 Settings
    Google Storage is now in S3
    All your passwords

    I've tried to do that, but there are no options there for S3 when I edit the jobs, despite S3 being set up for the jobs before? When I look at the list of jobs, under the Destinations column S3 is still listed, but when I edit the job, there is no S3 tab, and the S3 options don't appear under any of the other tabs there.

    How can I fix this?



  2. cyberetto
    Posted 3 years ago #

    And now after making some other changes S3 has disappeared from the Destinations column when looking at the list of jobs.

  3. mrkingid
    Posted 3 years ago #

    from a different post...

    file with error: class-cron.php on line 140 & 141
    $temp_fodler = scandir( BackWPup::get_plugin_data( 'TEMP' ) );
    foreach ( $temp_fodler as $temp_file ) {
    $temp_fodler should be $temp_folder

    fix that and S3 will show up.

    Also you need at least php5.2.6

  4. cyberetto
    Posted 3 years ago #

    Thanks so much, @mrkingid. That tip worked! That enabled the S3 option to appear on the first tab.

    I did run into a bunch of other errors with S3, such as, despite "US - Standard" being selected:

    Fatal error: Uncaught exception 'Guzzle\Service\Exception\ValidationException' with message 'Validation errors: [LocationConstraint] must be one of "EU" or "eu-west-1" or "us-west-1" or "us-west-2" or "ap-southeast-1" or "ap-northeast-1" or "sa-east-1"' in /home/cybnet/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Command/AbstractCommand.php:376 Stack trace: #0 /home/cybnet/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Command/AbstractCommand.php(272): Guzzle\Service\Command\AbstractCommand->validate() #1 /home/cybnet/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Client.php(223): Guzzle\Service\Command\AbstractCommand->prepare() #2 /home/cybnet/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Command/AbstractCommand.php(162): Guzzle\Service\Client->execute(Object(Guzzle\Service\Command\OperationCommand)) #3 /home/cybnet/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Command/AbstractCommand.php(213): Guzzle\Servic in /home/xxxxx/public_html/about/wp-content/plugins/backwpup/sdk/Aws/Guzzle/Service/Command/AbstractCommand.php on line 376

    Lots of errors still. Am running a backup now, and will see how that goes.

  5. Matt
    Posted 3 years ago #

    I fixed those lines, but still don't see S3 anywhere. The server I'm on is running PHP version 5.2.17, so I should be good there. Any other ideas?

  6. Matt
    Posted 3 years ago #

    Actually, when I looked at backwpup.php, I saw this line:

    if ( function_exists( 'curl_exec' ) && version_compare( '5.3.3', PHP_VERSION, '<=' ) && class_exists( 'BackWPup_Destination_S3' ) )

    So it looks like in order to continue to use S3, you have to be at version 5.3.3 or higher. Am I reading that correctly?

  7. Matt
    Posted 3 years ago #

    Looks like that's it; just looked up the Amazon S3 php sdk that this plugin includes and found this mentioned in the Readme:

    Minimum requirements
    PHP 5.3.3+ compiled with the cURL extension
    A recent version of cURL 7.16.2+ compiled with OpenSSL and zlib

  8. Daniel Hüsken
    Plugin Author

    Posted 3 years ago #

    @Matt: Yes it is correct. The most new SDK all developt with PHP 5.3+.

    @mrkingid: i have found the bug and fix it.

    @cyberetto: the problem is only on buckt creation in US Standart. I think it is a problem of the sdk. Create the buckt with the AWS S3 Console will work https://console.aws.amazon.com/s3 with the plugin too.

  9. nadworks
    Posted 3 years ago #

    Whua, whau wait a minute.
    My S3 has completely disappeared, too. Not cool, Daniel.
    So, in order to get it back I need to upgrade all of my hosted domains using BWPU to PHP 5.3.3 all of a sudden?
    And that without warning and a bit of an advanced heads-up?

  10. scott.hepler
    Posted 3 years ago #

    Oh, boy -- this has bitten me, too. I feel very unhappy.

  11. Caspar Hübinger
    Posted 3 years ago #

    @nadworks You can also grab an older version from here until you're ready to move to PHP 5.3.3: http://wordpress.org/extend/plugins/backwpup/developers/

    Granted, a bigger warning than the one in Description (pulled from the readme file) would have been appropriate, but then again: don't you guys never click the Details link next to the upgrade message?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BackWPup - WordPress Backup Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic