WordPress.org

Support

Support » Plugins and Hacks » EZ Emails » [Resolved] s2member Compatibility

[Resolved] s2member Compatibility

  • First of all, HUGE fan of the plugin. And the recent update that lets you drag and drop groups is the best update yet! My problem is that it is not compatible with s2member groups. It doesn’t list Bronze, Silver, etc and only Free, Contributor, etc.

    If you can fix that, then I’d be a HUGE fan and eternally grateful, and DEF up for making a donation!!!

    https://wordpress.org/plugins/ez-emails/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author luigipulcini

    @luigipulcini

    Thanks for the comments and the appreciation.
    First of all I want to double check that what you are describing is an actual incompatibility between the two plugins. As a matter of fact, I would find strange that EZ Emails lists some of the groups but not all of them.
    For this reason, I remind you that EZ Emails lists only the roles with at least one user. So, as an example, if your website doesn’t have any user listed as an “Editor”, you won’t find any draggable tag for that role.

    If you are sure that EZ Emails is not listing roles that include users of your website, I will look further into that problem and get back to you as soon as possible.

    I figured out the problem. s2Member’s default groups have more than one word in them (ie Bronze Member). After going in and changing them all to 1 word it works fine.

    P.S. Thanks for your quick attention btw.

    Wait… don’t close this out yet. Somehow it defaulted back to not showing up again. I’m going to do some troubleshooting right now and get back to you.

    Okay, I was wrong before. I had too many of the same name I think.

    Anyway, I installed the plugin User Role Editor. I created new roles and duplicating their functions to match the s2member roles. Once I did that, they showed up in EZ Mail. Changed all the roles to the User Role Editor names and I’m good. Just have to remember to change each one as it changes until you have a solution for me.

    I’d be glad to give you an admin if you want to log in and try it out.

    Plugin Author luigipulcini

    @luigipulcini

    You have already given me a hint of what could cause this problem.
    If it happens with role names including spaces, it is because of how WordPress queries the users per each role.
    Let me look into it and I will get back to you as soon as possible.

    Plugin Author luigipulcini

    @luigipulcini

    Apparently roles containing spaces must be searched with underscore instead. For example, “Silver Member” should be rather searched as “Silver_Member”.
    I did some experiments and it seems to work now on my side.
    Please let me know.

    Plugin Author luigipulcini

    @luigipulcini

    I forgot to mention: please update to version 2.2.5.

    Plugin Author luigipulcini

    @luigipulcini

    I would love to know if your issue got resolved with the latest updates.
    Thank you.

    Plugin Author luigipulcini

    @luigipulcini

    With version 2.2.7, this issue should be resolved now.

    I don’t know if you prefer I start a new thread or not.

    I get the error “An error occurred while sending this message: error: Could not instantiate mail function.” when trying to send an email.

    I suspect that this is because my email is domain.com and my site is installed at domain.com/home.

    Got a fix for me?

    Scratch that. I figured it out. It was the PHP version I was using. Thanks again for all the help.

    P.S. I can’t send over 30 at a time but I’m guessing that’s an issue on my end?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] s2member Compatibility’ is closed to new replies.
Skip to toolbar