Support » Plugin: All-in-One Event Calendar » s2Member causes AI1EC Calendar fail fetching events, only for non-Administrator

  • Resolved devra

    (@devra)


    We are using Timely All In One Event Calendar (AI1EC). Calendar pages display correctly. However, when users click to advance to the next month, or go to the previous month, the action fails with the following message:

    Something went wrong while fetching events.
    The request status is: 200
    The error thrown was: SyntaxError: Unexpected token <
    Click here for technical details

    In the role of Administrator, I do not experience this error. The calendars work fine for me. The error occurs for non-Administrator users who are logged in, and visitors who do not login.

    I went through my plugins and discovered that disabling s2Member Pro clears up the problem. We are using s2Member Pro to control access to specific pages based on role (10 levels). We have calendars on a few pages. The error occurs on a page which is not restricted, as well as on pages restricted to certain user levels.

    From my reading through the Forum, I have tried turning off/on the AI1EC Settings > Advanced Settings for “Use frontend rendering” and “Use advanced JS cache”, and this makes no difference. I have tried toggling “Strict compatibility content filtering” with no effect. And finally I tried changing the Calendar Theme from Vortex to something else, and back again, and resaving Permalinks.

    The default calendar page is restricted to users with Admin authority. The calendars with this problem are being generated using shortcodes, specifying different categories on different pages.

    I have a beta site which was cloned from the live site, which was experiencing the same problem. I deleted and restored the plugin as follows:
    • Deleted /wp-content/plugins/all-in-one-event-calendar/uninstall.php
    • Deactivated the plugin.
    • Deleted the plugin.
    • In PHPMyAdmin, deleted all ai1ec entries from the wp-options table.
    • Reinstalled plugin.
    • Reset default calendar.
    • Cleared Cloudflare cache.

    This fixed the problem on the beta site. But when I followed the same procedure on the live site, it did not fix the problem. Because I just couldn’t believe it, I tried uninstalling/reinstalling multiple times. I also tried toggling off/on the settings mentioned above after the reinstall. I did not see any helpful information in Firebug. Without logging into our site, you can see a mini calendar at the bottom of this page which recreates this error consistently: http://www.thewilloughbychevychase.com/life-at-the-willoughby/amenities/party-room/

    I would be grateful for any further advice. I really don’t want to abandon the Timely All In One Event Calendar. My thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello Devra,

    Are you using any custom permalinks plugin on your live site?

    I ask because a previous user reported the same error you describe, and it was caused by a plugin called “Custom Permalinks” — disabling and removing the plugin fixed the error.

    Please advise.

    For faster assistance, please log into your Timely account and open a ticket by clicking on the Get Help link, or click here: https://dashboard.time.ly/account/get-help

    Please post your question again using the above link.

    [ Moderator note: Signature redacted. ]

    • This reply was modified 2 years, 7 months ago by Jan Dembowski.

    Hi, Sunny.

    Thank you so much for responding. Somehow this issue has been marked as resolved, which it is not. But I seem unable to change that status.

    We do not have any plugins which mess with permalinks. The plugin which causes the problem is s2Member. And the problem only exists for non-Admin users. Unfortunately, I reported above that I had fixed the problem on our beta site, but it’s broken again.

    Thanks for the link. I’ll open a ticket with time.ly

    The Get Help link is unavailable. Is Time.ly support only available for Premium accounts?

    Hello Devra,

    Apologies for the issue you are experiencing. Support is available for all customers.

    It is apparent that the problem is caused by access control, I believe your S2Member Pro plugin does not recognize Events (just pages and posts) hence the error while the plugin is active. I would suggest contacting the plugin vendor and ask for their support on how to eliminate the error by possibly modifying their plugin to accomodate events from our calendar.

    [ Moderator note: Signature redacted. ]

    • This reply was modified 2 years, 7 months ago by Jan Dembowski.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘s2Member causes AI1EC Calendar fail fetching events, only for non-Administrator’ is closed to new replies.