Support » Fixing WordPress » RunPHP not working for me…

  • I’ve had RunPHP installed on all of my WP sites, but have never been able to use it.

    I unchecked: WordPress should correct invalidly nested XHTML automatically
    And have cheked eval()content in page
    Am using [ instead of <

    I’m trying to test it with:
    [?php echo ‘Test’; ?]

    But still doesn’t work.

    Any ideas?


Viewing 6 replies - 1 through 6 (of 6 total)
  • Mark (podz)


    Support Maven

    Plugin Name: Run PHP
    Version: 0.2.2
    Plugin URI:
    Description: Allows PHP to run in posts by using custom HTML style tags
    Author: Mark Somerville
    Author URI:

    That uses <phpcode> </phpcode> does it not ?



    The PHPExec plugin uses the <phpcode> tags.
    I tried that and it worked.
    So I went back and tried the other and it started working too.

    But not until after I made sure I had removed the php header, sidebar, footer and other tags that were being redundant. That was because I had originally used a page modified as a template rather than an include.

    Did I confuse everyone?




    Run PHP is a must have plugin… I love it!

    I am however wondering if it is still safe to use on 2.0 seeing that the user level things are different.



    Per the Plugin Compatability list,
    RunPHP doesn’t work under WP2.0 but Exec-PHP does.

    If you’re not running a lot of PHP inside of pages and want to upgrade now, you can just switch plugins.



    I run PHP EXEC but it doesn’t work on mine aft my upgrade..

    I tried using

    echo “Current date and time: “;
    echo date(“l dS of F Y h:i:s A”);

    but it doesn’t work on mine, any idea?



    PHP EXEC is also known to not work. There was a change to the way that posts and pages are processed.

    The Exec-PHP and WP-Exec plugins do work. With your current code, Exec-PHP would be a drop-in replacement.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘RunPHP not working for me…’ is closed to new replies.