WordPress.org

Forums

TinyMCE Advanced
[resolved] Running WP 4.0 Beta and TinyMCE Advanced Editor Menu missing from visual editor (14 posts)

  1. Karalee
    Member
    Posted 10 months ago #

    I posted this on the WP 4.0 beta forum, and they suggested I let the plugin developer know, which is what I am doing now. If you prefer that I post these issues elsewhere or not at all, please let me know. So, I'm running the latest WP beta software on site with version 4.0.2 of TinyMCE Advanced plugin. When I go to visual editor, I still see the buttons, but the Editor Menu that used to display just above the buttons no longer appears. FYI, the site where I am running the WP 4.0 software is an exact duplicate of a site where I am running WP 3.9.1. The only difference I have encountered with your plugin on the two sites is the Editor Menu issue.

    https://wordpress.org/plugins/tinymce-advanced/

  2. majecdad
    Member
    Posted 10 months ago #

    I can confirm, I have the exact same issue here. Only a problem in WP 4.0b2 with TinyMCE 4.0.2. Fine in WP 3.9.1.

    Disabled every other plugin, so its not a plugin conflict.

  3. progreen82
    Member
    Posted 9 months ago #

    Same issue with 3.9.

  4. spameur
    Member
    Posted 9 months ago #

    Same issue with WordPress 4.0-beta3-20140812

  5. Karalee
    Member
    Posted 9 months ago #

    This issue is now resolved on all of my sites running the latest beta release, 4.0-RC1. When I edit a post/page, I see both the buttons and the Editor Menu above them.

  6. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 9 months ago #

    Yeah, was a conflict with the editor scroll feature in WordPress 4.0. Should work as expected now in RC-1.

  7. titaniumbones
    Member
    Posted 8 months ago #

    I just posted a new bug, so sorry for crossposting -- in distraction-free mode, 4.0RC1, the editor menu now cuts off the first line of text from a post. I took a quick look at the html for the editor but there are so many container elements I had a hard time verifying anything except that when I eliminated the whole titlebar, the problem went away. thanks,

    Matt

  8. Karalee
    Member
    Posted 8 months ago #

    I'm not seeing this exact issue on my sites. When I switch to distraction-free mode, the first line of text is right beneath the editor menu with no gap between them. However, the editor menu is not cutting off any text on my posts or pages.

  9. lucidlips
    Member
    Posted 7 months ago #

    I am experiencing a similar issue to this, my visual editor has no scroll bar nor scroll functionality and in distraction free mode the entire screen goes blank. Does any know if our problems are related?

    im running wordpress 4.0 and tinymce advanced 4.1.1.

  10. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 6 months ago #

    These are new in WordPress 4.0. Can be turned off from Screen Options (top/right).

  11. rahul_wpfreak
    Member
    Posted 3 months ago #

    I am running wordpress version 4.1.1. I am facing issue with visual editor has no scroll bar and add link button is no more working. When i click to link button in editor i got Error message something like this in js error console
    "TypeError: f.wrap is undefined" and showing me error in wp-admin/load-scripts.php file.

  12. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 months ago #

    Add define('SCRIPT_DEBUG', true); to your wp-config.php file (read more about how to do it in the codex first!). Then find out exactly which JS file is throwing that error.

    Then see if the plugin that adds that file has an update/fix, or post here so I or somebody else can have a look and try to help :)

  13. altenide
    Member
    Posted 2 months ago #

    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/thickbox/thickbox.css?ver=4.1.1"
    thickbo...r=4.1.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.15.1"
    mediael...=2.15.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/mediaelement/wp-mediaelement.css?ver=4.1.1"
    wp-medi...r=4.1.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/imgareaselect/imgareaselect.css?ver=0.9.8"
    imgarea...r=0.9.8
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tw-sack.min.js?ver=1.6.1"
    tw-sack...r=1.6.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/css/editor.min.css?ver=4.1.1"
    editor....r=4.1.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/tinymce.min.js?ver=4107-20150118"
    tinymce...0150118
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/plugins/compat3x/plugin.min.js?ver=4107-20150118"
    plugin....0150118
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/langs/wp-langs-en.js?ver=4107-20150118"
    wp-lang...0150118
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tw-sack.min.js?ver=1.6.1"
    tw-sack...r=1.6.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/css/editor.min.css?ver=4.1.1"
    editor....r=4.1.1
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/tinymce.min.js?ver=4107-20150118"
    tinymce...0150118
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/plugins/compat3x/plugin.min.js?ver=4107-20150118"
    plugin....0150118
    ReferenceError: tinymce is not defined
    post.ph...on=edit (ligne 2244)
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/tinymce/langs/wp-langs-en.js?ver=4107-20150118"
    wp-lang...0150118
    ReferenceError: tinymce is not defined
    post.ph...on=edit (ligne 2238, col. 36)
    "NetworkError: 403 Forbidden - http://www.melanie-corvez.fr/wp-includes/js/thickbox/loadingAnimation.gif"
    loading...ion.gif

  14. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 months ago #

    @altenide: "NetworkError: 403 Forbidden" = install problem (file permissions) or server configuration problem. Contact your hosting company, they should be able to fix this easily.

Reply

You must log in to post.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.