Support » Fixing WordPress » running default theme

  • Hello,
    My site which had its own theme is hacked and now i deleted all its files and folders.

    I want to try the default theme now. So i downloaded the clean, new copy of wordpress here. then i uploaded that wordpress to my site.

    then it wanted to run installation and i entered db, username and password and hostname but it says wordpress is installed already and i must clean my old tables etc. i do not want to touch my database. my db is fine. all i wanted was to delete hacked files and folders, and now i am uploading a clean copy.

    how can i upload and run the clean wrdpress without installation? i guess i must change a file for not running installation and enter db name and passowrd etc after i upload wordpress manually so it doesnt run installation but runs my site instead? which file and where?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hello Kentanco,

    Sorry to hear about your website being hacked, it happened to me a while ago and I used this article as a guideline to not only retrieve my files but also to make my website a bit more safer to avoid the hacks.

    The main thing is you want to edit your WordPress.config file with your new DB password and make sure that your wordpress installation is pointing to that database and not the other one.

    You can go through this article and let me know if this helped you: https://torquemag.io/2016/03/wordpress-sites-hacked/

    Thread Starter ketanco

    (@ketanco)

    hi
    thanks good article but i missed or it is not there… my question was, after i install a fresh wordpress, in order to avoid installation, and just bring up my current site with a defaut theme, which file or files exactly i must change in freshly innstalled default wordpress so that it doesnt run installation but just brings up my site?

    Hello Kentanco,

    As Julius said, you will have to edit your wp-config.php file (in the root of your install) with your old database credentials and that should bring up the site for you. You don’t have to go through the install process again if you’re using the old database. When you enter the credentials and save the wp-config.php file you should be able to access the site by going to the site.com/wp-admin url. You may have to go into Appearance > Themes and choose the default theme you want to use.

    https://codex.wordpress.org/Editing_wp-config.php

    Thread Starter ketanco

    (@ketanco)

    i dont see a wp-config.php but i see a wp-config-sample.php, so i do these entries there and rename the file to wp-config.php?

    Thread Starter ketanco

    (@ketanco)

    and when i did so, i mean edit wp config sample php and renamed it to wp config, it just shows empty now. nothing, just white screen when i type my site name

    Yes – you’re correct in renaming it. It should be wp-config.php. Make sure you entered the database name, username and password correctly.

    If you have a backup from your old site, you can copy that and upload it but before that, try going to yoursite.com/wp-admin

    Can you get there and login with your old credentials?

    Thread Starter ketanco

    (@ketanco)

    no i can not

    Is it letting you get to the login screen? If not, is it giving any error message?

    Thread Starter ketanco

    (@ketanco)

    my site name is roboticmagazine.com

    it says this:

    Secure Connection Failed

    An error occurred during a connection to roboticmagazine.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

    m

    Thread Starter ketanco

    (@ketanco)

    again, i am now trying with a fresh wordpress copy i downloaded from here. i just want to see if i can run it. i renamed the file to wp-config.php and entered database name and password and hostname etc… and then … nothing. when i type my site name, just blank screen

    Do you have an SSL installed on the site? That part seems like an SSL error.

    Can you try adding/editing the following in your wp config file? Change example.com to your domain.com but keep it http not https.

      define('FORCE_SSL_ADMIN', false);
       define( 'WP_HOME', 'http://example.com' );
       define( 'WP_SITEURL', 'http://example.com' );
    
    • This reply was modified 2 years, 11 months ago by Joe Nickdow.

    ketanco, when you do a fresh install of WordPress without changing anything what happens… Please take us step by step through your installation process.

    Then also are you installing it on a shared hosting account or on a personal server that you have created.

    If you are using a hosting company, which company is it and have you tried to consult with them as well?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘running default theme’ is closed to new replies.