Support » Installing WordPress » Running but some things not working

  • Resolved dasanudas

    (@dasanudas)


    My ISP had WP Version 1.something. I installed it and then upgraded to the latest version. It seems to be working–I can edit and post stuff, and add comments, but the categories links and RSS feed seem to be broken. I am a PHP absolute newbie and don’t have a clue how to troubleshoot this stuff. Any ideas?

    http://esotericteaching.org/blog

    David

Viewing 15 replies - 1 through 15 (of 15 total)
  • Big 404 – Not found.
    Check the URI you provided.

    Yeah, I tried re-installing everything in the default directory. Try

    http://esotericteaching/wordpress

    Now the funny thing is, the RSS was working with the sample post. Now I made a couple of test posts, and the RSS and categories seem broken again.

    No link is working on that site. Are you sure you have mod_rewrite and a writable .htaccess file?

    Well that’s a good question. The server is running a recent version of Apache. Where should the .htaccess file be located and what should it contain?

    Before checking that – make sure you have mod_rewrite on your server, because if you don’t no need for… better to say, no use of .htaccess.
    If you are not sure about the mod_rewrite, make a clean file that has only this as content:
    <?php
    phpinfo();
    ?>

    and save it as info.php – upload to your root and go and open it in a browser.

    Well, I created an empty .htaccess file and put it in the wordpress root. The system went belly-up with a 500 error. OK, deleted the .htaccess file, put in the info.php file, and now I have a huge response with more than I ever wanted to know. mod-rewrite appears under the list of ‘loaded modules’. Now what?

    What I’d try – if you insist on using “nice” permalinks.
    Upload the empty .htaccess file BUT do not attempt to see your blog. Go into the admin > Options > Permalinks and set up your permalinks as you want then hit the Update button.
    If the .htaccess file is writable it will say everything is OK. If it isn’t, it will display the code that you are suppose to copy/paste into the .htacces file.

    OK, I created a blank .htaccess file in the WP root. Updated permalink structure, and it gives me a bunch of code to paste into the file.

    But the docs say that WP should be able to create/update this file automatically. The permissions for the WP directory are rwx r-x r-x. The permissions for the .htaccess file are rw- r– r–. Do I have a permissions problem?

    OK, I updated the permissions code and the site works properly. Still I think I have a permissions issue. How should I set the permissions for that folder & file?

    Mine didn’t work unless I made the .htaccess rw-rw-rw (666).
    And I just said above it will give you the code to paste into the file if it isn’t writable.

    Which folder and file?
    From here everything works as it supposed to.

    Easiest way is to delete all the stuff on the permalinks text box; go to file manager or your install folder in your ftp client, change permissions on .htaccess to 777, go back to wp, on the permalinks section, input whatever you want the permalinks to do in the text fields, now that .htaccess is writable, wp will handle the input for you. Go back to file manager or your ftp client, reset the permissions on .htaccess to 644 (rw – r – r). I run 8 blogs with .htaccess set up like this, works just fine (which will, though, as pointed out by moshu, depend on your host’s particular server setup).

    I went mucking around in the File Manager and set the file permissions for .htaccess to rw- rw- rw-. Now I can set the Permalink structure from the Options page. Yay!

    dasanudas,
    You wrote about a problem related RSS feed to other site from wordpress blog. Are you using this link for RSS syndication?
    /wp-rss2.php

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Running but some things not working’ is closed to new replies.