Support » Plugin: Wordfence Security - Firewall & Malware Scan » Rules Update Failing

  • Resolved TheRealMikeD



    I just saw a notice in my dashboard that said, “The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was March 14, 2019 12:26 PM, so this site may be missing new rules added since then. You may wait for the next automatic attempt at April 1, 2019 5:16 PM or try to Manually Update by clicking the “Manually Refresh Rules” button below the Rules list.”

    When I try to manually refresh (and btw, it took me several minutes to find the manual refresh button – a link to the correct settings page in the message would have been much appreciated), I got this pop-up message: “No rules were updated. Please verify your website can reach the Wordfence servers.”

    Looking through the Diagnostics tab, everything looks to be in order (“Connecting to Wordfence servers (http)” and “Connecting to Wordfence servers (https)” both say “OK”). So what might be the problem?

    Using Wordfence 7.2.4 and WordPress 5.1.1.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support wfdave



    In the newest version of Wordfence, the timeout for the rule update has been adjusted.

    Can you try updating to the latest version and try to download the rules again?


    • This reply was modified 5 months, 4 weeks ago by  Jan Dembowski.


    Is 7.2.4 not the latest version? I can’t seem to find anything newer.

    Plugin Author WFSupport


    Thanks @npiper! Can the rest of you try deleting the wp-content/wflogs/rules.php file and letting Wordfence rebuild it?


    I confirm that deleting rules.php did not work.

    Furthermore, I checked a few other sites that I manage, and all of them are having the same issue. All are running Wordfence 7.2.4.

    Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    Hi! If you are not the person who opened this topic and if you need support then per the forum guidelines please start your own topic.

    You can do so here.

    Someone asked which hosting service we were all using (did those comments get deleted?). A lot of people replied that they were using Dreamhost. I am using Dreamhost as well. Not conclusive, but it might be worth inquiring with Dreamhost about the issue.

    Plugin Author WFSupport


    It has come to our attention that one of our servers where scan signatures and firewall rules come from is being blocked for some reason by a few hosting providers like Dreamhost. If you are not getting your rules updated and are hosted by Dreamhost (or any another hosting provider for that matter) please ask the provider to check and see if ( is being blocked. If it is, ask them to unblock it for ports 80 and 443 and let us know if this was the case. If Dreamhost is blocking the IP then they are the only ones that can do anything to fix this.


    Thanks, Tim! I filed a ticket with Dreamhost. I’ll post here when they respond.

    Plugin Author WFSupport


    Just a quick update from our side. Dreamhost’s team has identified some other possible blockages that we’re looking into. However, we’ve had reports of the rules now updating on Dreamhost’s servers. Please check your installation of Wordfence to see if you can now update the firewall rules.


    All four of my Wordfence-enabled sites (all hosted on Dreamhost) are updating as expected now.

    Thanks for hunting the cause of this issue down, Tim & WF Team!


    I have the same problem. In WP Admin I can see error
    No rules were updated. Please verify your website can reach the Wordfence servers.
    Version of Wordfence Plugin is Version 7.2.5. How it can be fix ? If hosting says that it’s ( is unblock.


Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.