Support » Plugin: Wordfence Security - Firewall & Malware Scan » Rules not getting updated

  • Resolved Enrique Gonzalez

    (@rickyprice)


    The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was March 13, 2019 4:04 pm, so this site may be missing new rules added since then. You may wait for the next automatic attempt at March 27, 2019 4:06 pm or try to Manually Update by clicking the “Manually Refresh Rules” button below the Rules list.

    Then I get on my site https://pontik.com

    Rule Update Failed
    No rules were updated. Please verify you have permissions to write to the /wp-content/wflogs directory.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • zsujoker

    (@zsujoker)

    I havethe exact same issue.
    I have tried to update manually, but without success.

    Please help!

    Thanks.

    Zsuzsa

    aaroa

    (@aaroa)

    I have the same problem. Waiting for solution.

    lanxalot

    (@lanxalot)

    I have the same issue. Hopefully there will be an update soon.

    einstem

    (@einstem)

    Same issue as well.. just happened in the last few days.
    Presume an update broke something perhaps?
    Hopefully they will fix this, but a response would be nice..
    Michael

    Jan

    (@janchu4)

    Same issue. Has been this way for a few days.

    dereckbp

    (@dereckbp)

    Same, and last update did not fix it

    Plugin Author WFSupport

    (@wfsupport)

    We released an update that should have fixed this yesterday. Can you make sure you have the last update (7.2.4) and manually updating the rules? If that doesn’t work can you try deleting the rules.php file in wp-content/wflogs? Let Wordfence automatically regenerate the file (usually within 30 minutes) and see if the issue is resolved.

    Tim

    The big site https://adondeirhoy.com refreshed the rules correctly. The other one https://pontik.com gave me this message

    No rules were updated. Please verify your website can reach the Wordfence servers.

    I will try removing the rules.php file and let you know.

    kingkaysar

    (@kingkaysar)

    Getting error

    No rules were updated. Please verify your website can reach the Wordfence servers

    Rob Yardman

    (@robyardman)

    Having the same error:

    No rules were updated. Please verify your website can reach the Wordfence servers.

    Have also deleted: /wp-content/wflogs/rules.php

    Plugin Author WFSupport

    (@wfsupport)

    It has come to our attention that one of our servers where scan signatures and firewall rules come from is being blocked for some reason by a few hosting providers like Dreamhost. If you are not getting your rules updated and are hosted by Dreamhost (or any another hosting provider for that matter) please ask the provider to check and see if noc4.wordfence.com (69.46.36.20) is being blocked. If it is, ask them to unblock it for ports 80 and 443 and let us know if this was the case. If Dreamhost is blocking the IP then they are the only ones that can do anything to fix this.

    Tim

    Plugin Author WFSupport

    (@wfsupport)

    Just a quick update from our side. Dreamhost’s team has identified some other possible blockages that we’re looking into. However, we’ve had reports of the rules now updating on Dreamhost’s servers. Please check your installation of Wordfence to see if you can now update the firewall rules.

    Tim

    having the same issue

    hosting on azure

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.