Support » Plugin: Pricing Deals for WooCommerce » Rules applying on top of each other

  • Resolved constance709it

    (@constance709it)


    Hi! Fantastic plugin with great documentation!
    I am having trouble with the rules stacking on top of each other regardless of my having the settings set as per your walkthrough including setting the priorities.

    I even turned on the “Only one rule per cart allowed” under settings as you suggested in another post and it still isn’t working.

    Please advise. Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author vark

    (@vark)

    Hi,
    Thanks for your kind words!!

    Looks like something is getting in the way of Pricing Deals on your site….

    You likely have a memory, caching or module conflict issue.

    (A) Set your memory to a minimum of **512mb** , the de-facto memory standard (or greater!)
    (** Double-check ** the following, even if already set to 512mb.)
    (*) Memory should be *explicitly* set in *both* the php.ini (host) file,
    and in the wp-config.php file .
    – call your HOST to **Confirm or Set** the explicit setting of 512mb of memory in php.ini
    – update your wp-config.php file with a statement like this: define(‘WP_MEMORY_LIMIT’, ‘512M’);

    (B) Caching:

    Do you have a caching plugin (W3 Total Cache, etc)
    or does your HOST offer caching services (**Varnish, Cloudflare, etc)**?
    – If so, please **clear the caching plugin cache**. Test. **Turn off caching**. Test.
    – If that isn’t it, carry on…
    (Pricing Deals is happy, however, with ** WP Super Cache: by Automattic ** , which seems to keep up better )

    (C) if that’s not it , suggest a *full module conflict test*:

    To track down a module conflict, please follow these steps ** PRECISELY **:
    (1) Install and activate a maintenance mode plugin (if desired)
    (2) Then, DO ALL (*at the same time*):
    (-) do a full site backup!
    (-) deactivate ***all*** plugins except Woo, my plugin (and maintenance mode plugin)
    (-) ** switch to a clean default theme like 2017 **
    — (This removes all other possible conflicts.)
    (-) turn off all deals except the one we are examining.

    (3) ** test **
    (4) if good, add 1 module back in. ** Retest **
    (5) Repeat until conflict identified.

    ** This test depends on following the outlined steps fully. **

    Best,
    Vark

    (PS – If you do have a module conflict, it will likely boil down to choosing between the 2 conflicting modules…)

    Thank you for the quick reply! I will follow your instructions and hopefully figure it out quickly.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Rules applying on top of each other’ is closed to new replies.