Support » Plugin: Wordfence Security - Firewall & Malware Scan » Rule update that wont reset

  • good day

    please could you help remove the following message from my dashboard.

    The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was March 1, 2019 21:55, so this site may be missing new rules added since then. You may wait for the next automatic attempt at March 15, 2019 21:56 or try to Manually Update by clicking the “Manually Refresh Rules” button below the Rules list.

    • This topic was modified 6 months, 1 week ago by  victaurus.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Were you able to refresh the rules manually?
    I have the same problem. And I can’t update rules manually either.

    I just found a solution that worked for me:Deleting the wflogs folder from wp-content. This deletes the existing rules and gets recreated when someone visits the site automatically. Suggested in this thread: https://wordpress.org/support/topic/rule-update-failed-wordfence-7-1-8/

    Are there any other solutions? This just created an empty rules file for me, and still wouldn’t update. I restored the folder for now, but it’s still not updating that either. Thanks.

    I have the same problem, deleting the file does not change anything. Did you succeed ?

    @victaurus, @zirq, @nathoudu38 have you checked what @wfchar suggests?

    You’ll need to speak to your host or server administrator about curl_exec() being disabled, as that functionality is used by the firewall and is likely behind the rules not being generated. Once that has been re-enabled, you should be able to go through the regeneration routine and have wafRules.rules generate correctly.

    zirq

    (@zirq)

    The part about running debugging on WordPress itself? No, I hadn’t, was hoping there was a newer solution, since it seemed like a few people are all running into this issue right now. I’ll try it in a few hours. Thanks.

    nathoudu38

    (@nathoudu38)

    The time on the FTP changes when I click on the button Manually refresh rules! Apparently the file is updating but there is a fake error message

    Plugin Author WFSupport

    (@wfsupport)

    We released an update that should have fixed this yesterday. Can you make sure you have the last update (7.2.4) and manually updating the rules? If that doesn’t work can you try deleting the rules.php file in wp-content/wflogs? Let Wordfence automatically regenerate the file (usually within 30 minutes) and see if the issue is resolved.

    Tim

    @wfsupport I have latest version and still won’t update rules manually. says not connecting to servers. I would put in support ticket but wordfence.com website locked me out for wrong email/password failed attempts.

    Sent email to feedback@wordfence, no telling how long that will take.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.