Support » Plugin: FeedWordPress » RSS/XML error for my other WordPress site

  • I’m syndicating one of my WordPress blogs to a couple of other WordPress blogs and up until 4 days ago this was working fantastically with FeedWordpress. However, now I am getting the following error:

    This XML document is invalid, likely due to invalid characters. XML error: Mismatched tag at line 30, column 117

    When I check the feed, there seems to be nothing wrong in that particular line and when I validate it, it says “This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.”

    This was also discussed in this topic, but a solution was not posted: https://wordpress.org/support/topic/plugin-feedwordpress-xml-errors-reported

    Does anyone know what I can do to solve this?

    https://wordpress.org/plugins/feedwordpress/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same problem here. I’ve asked the owner of one of the blogs with this issue and she said she has upgraded WordPress to the latest version some days ago.
    Is this your case too? I don’t know if the problem comes from this, anyway.

    I did upgrade. Would it be wise to reinstall the older version? FeedWordpress is one of the most important plugins I’m using so I need it to work.

    I don’t know… anyway it’s never a good idea to downgrade, sooner or later you’ll need to upgrade again.
    I hope someone will find a solution, I can’t ask someone else to downgrade his own WordPress 🙁

    Plugin Author C. Johnson

    (@radgeek)

    Hi @est90,

    Sorry to hear you are running I to this problem. I am out of town for the holidays but should have some time to I vestigate the issue soon. Would you be willing to send me the URL for the WordPress RSS feed where you’re getting the error message, so I could take a quick look at the details of what’s going on?

    -C

    For what it’s worth, I have the same problem. The Feed that get’s imported is http://evolutionradioshow.com/feed/

    I think the Line 30/column 117 is misleading, as it was a closing image-tag before updating on Monday and now it is a comment tag (which is only 93 char long)

    I couldn’t locate where the error comes from in feedwordpress code? Could it be from the SimplePie_Parser Class which it extend in feedwordpress_parser.class.php?

    If I knew where the error comes from I could debug more…

    @radgeek that would be great, thanks! The feed I’m using is http://usnewswires.com/author/usnewswires/feed/

    I hope someone is able to find out what the problem is!

    Hi,

    Have you find any solution to fix that issue. I have same problem.

    Hi Charles @radgeek. I’ll also crosspost this as an issue on github.

    I looked into this a bit more, but I had a hard time understanding the async/class structure of the code.

    The error message comes from line 1439 in wp-includes/class-simplepie.php.

    This got changed in the WordPress source on Sep 20 with a commit https://github.com/WordPress/WordPress/commit/84da11d91826f3de1210ecdca6156ab951a53d48 that added a new argument.
    I’m quite sure it’s something else though… Some other small changes with dates happened in the SimplePie Directory.

    SO how can we help futher debug this?

    Hi @radgeek, have you find a solution? I’ve sent you an email, now the feeds that don’t work are increasing 🙁

    I’ve found a solution!! It’s a workaround but I’ve been able to syndicate the feeds that didn’t work. Simply, set up Feedburner http://feedburner.google.com/ to create a new feed from the one that doesn’t work and use the resulting URL instead of the original one 🙂
    I have to thank Alan Levine (his blog is cogdogblog.com), he suggested me this solution.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘RSS/XML error for my other WordPress site’ is closed to new replies.