WordPress.org

Support

rss/atom

  • so i have done the basic install of wordpress and everything is fine except the rss/atom feed. i have poked around the forums here but have not found the problem.
    the blog can be found here (www.euclid.homelinux.net/~cinchel/wordpess/index.php) (yes i mistyped the directory when i installed…opps)

    the error i get is that ~cinchel/wordpess/feed/rss2 does not exist….when i click on the feeds link on the left column….

    when using firefox to add the feed..i get live bookmark failed to load…

    thank you for any and all help

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator James Huff

    @macmanx

    Unfortunately, you’re using permalinks which make use of /index.php/. Under this scenario, the /feed/rss2/ links will not work. You will have to open index.php either in a text editor or the Templates menu and manually replace all feed links with the original /wp-rss2.php URL.

    thank you for that info…i had tried the other option for permalinks…and adjusted the .htaccess accordingly but then comment links didnt work…

    changing the 2 lines in index.php has gotten the links in the “meta” section to work but is there a way to get the icon on thebottom right of firefox that adds rss feeds to point directly to wp-rss2.php?

    thanks again

    Moderator James Huff

    @macmanx

    Find all of your RSS links in index.php and change them to:
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.domain.com/wp-rss2.php" />

    thank you …that worked perfectly….

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘rss/atom’ is closed to new replies.
Skip to toolbar