[resolved] RSS: XML or text declaration not at start of entity (11 posts)

  1. paulolyslager
    Posted 5 years ago #

    My feed:

    As you can see I get an error:
    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.paulolyslager.com/feed
    Line Number 3, Column 1:<?xml version="1.0" encoding="UTF-8"?>

    I've been looking in the wordpress forum and found the fix-rss-feed plugin, which deletes blank lines. But no results.

    Through feedburner I can ping to my feed, which works.

    The feed validator of feedburner showed me this:
    line 1, column 1: Blank line before XML declaration
    I've been digging into the code of wp-rss2.php, wp-atom.php, functions.php but can't find any blank line...

    Someone has other idea's? Would be most welcome.



  2. paulolyslager
    Posted 5 years ago #

    Just tried different browsers:

    FF, IE, chrome and Opera don't show the feed.

    In Opera:

    XML parsing failed: syntax error (Line: 3, Character: 0)

    Reparse document as HTML
    Error:XML declaration not at beginning of document
    3: <?xml version="1.0" encoding="UTF-8"?><rss version="2.0"
    4: xmlns:content="http://purl.org/rss/1.0/modules/content/"
    5: xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    6: xmlns:dc="http://purl.org/dc/elements/1.1/"

    Safari shows the feed just nicely!

  3. paulolyslager
    Posted 5 years ago #

    Ok, fixed the problem and it works in all mentioned browsers... Really weird but really easy... just cleaned my header :)

    I had some blanc lines in there to visually seperate the metatag-lines, rss-lines, blogname-lines, ...

    I hope it works for the other people as well!

  4. paulolyslager
    Posted 5 years ago #

    Hmmm, spoke too soon...

    the feedburner link is working... the normal feed (http://www.paulolyslager.com/feed) is still not responding.

    Let me know if someone has an answer!

  5. Samuel B
    Posted 5 years ago #

  6. Greetje
    Posted 5 years ago #

    He used that plugin already.
    I'm having exactly the same problems.

  7. paulolyslager
    Posted 5 years ago #

    Thank you for your replies... Yes, thank you Greetje... As mentioned before Samboll, i've tried the fix-rss-feed without any luck. Also cleaned up my header for any white spaces and still not working. Someone else has an idea please?

    @Greetje, let me know how it works out for you!


  8. paulolyslager
    Posted 5 years ago #

    ok, i found this article:


    It made me realise that the only php code i changed over the past few weeks was those of the theme files. I found a blanc line in my archive.php.

    Maybe you should those as well!

  9. pdbanimations
    Posted 5 years ago #

    I ve tried every single whitespace delete I can find and still no luck with this :(


    If anyone can see anything obvious I am missing by the link that would be great.


  10. James Huff
    Volunteer Moderator
    Posted 5 years ago #

    pdbanimations, your feed is working fine and it's perfectly valid:


    If you continue to have problems, please start your own topic.

  11. pdbanimations
    Posted 5 years ago #

    Thanks for response. Sorry for posting here found it on a google search. It is now working ... somehow lol! I went to work and come back and it now works spooky maybe it took a while to update or something.

Topic Closed

This topic has been closed to new replies.

About this Topic