RSS won't validate because of localization (10 posts)

  1. zwerg
    Posted 11 years ago #

    The RSS generator uses "mysql2date" function for the pubDate-tag. This function is also used in single.php of the Kubrick-theme. My german localization translates the $weekday and $weekday_abbreviation so that the weekdays appear in German. Like this, the RSS genereator produces something like <pubDate>Do, 03 Mar 2005 23:05:05 +0100</pubDate> though it should be <pubDate>Thu, 03...</pubDate> so the feed is not valid [0]. Shouldn't the RSS generator use some more generic weekdays description which is not translatable?

    [0] http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.c3w.de%2Ffeed%2F

  2. Kowalsky
    Posted 11 years ago #


    I have the same issue with a french localization.
    but I can see that your RSS does validate now.
    how did you managed to get it working ?


  3. akc
    Posted 11 years ago #


    The devs have fixed it: http://trac.wordpress.org/changeset/2366

    It's too late for me to explain it for those who need it boiled down, sorry :( if u're on the other side of the world, please help, thanx

    ps: might have to add a test entry to force browser to get a fresh feed so u can see the fix in action ( i was puzzled by this for several minutes). time to bed!!

  4. snowgoon
    Posted 11 years ago #

    Does this apply to post titles as well?

    My feed has broken after I posted some gaelic which includes e acute and a acute - which I posted as eacute; and aacute; - the title displays fine but the feed has since borked.

    Gave me this error:

    XML Parsing Error: undefined entity
    Location: http://www.gordonmclean.co.uk/wp/wp-rss2.php
    Line Number 82, Column 11:
    <title>L&aacute; Fh&eacute;ile P&aacute;draig</title>

  5. iand
    Posted 11 years ago #

    This should work (I think):

  6. akc
    Posted 11 years ago #


    No, this fix is specific to the localisation problem mentioned above. The problem you mention (HTML named entities mistakenly being included in feeds) should be easy to fix but I'm not familiar with the issue. A good solution would be for WP to convert all HTML entities (named or numeric) to their real Unicode characters (this has the advantage of being human-readable). In my blog I also use "special characters" for Taiwanese romanization, but I input them directly.

  7. snowgoon
    Posted 11 years ago #

    cheers akc.

    Doesn't really help though - I also entered the characters as "special characters" but I guess this might be more an RSS issue and the way it handles this stuff.

    I'm off to dig through the specs (RSS) to see what they have to say.

  8. zwerg
    Posted 11 years ago #


    Though the problem is fixed now, my solution was an evil hack which replaced german weekdays by english ones through regexp ;-)

  9. Kowalsky
    Posted 11 years ago #

    Hi all,

    thanks akc for the fix, been able to recover the date and time in my rss with the suggested fix, and it validates again.

    However I have found a strange behaviour in return. As we know, time used in WP is by default in UTC, and in the "option" panel, you can set a modifier to get the local time. (in my case: +2)

    What I have noticed is that although WP comments are correctly diplayed as time H +2, now I can see the RSS time displayed as H +4 .

    Any idea?

  10. Kowalsky
    Posted 11 years ago #


    found also the fix for the RSS time issue:

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.