Support » Plugins and Hacks » RSS Widget Feed Problems

  • I am having trouble fetching an rss feed and I suspect it is because of a special character in the url. I get no error, but no feed entries appear. I’ve verified fetching the feed with magpie independently and it works fine.

    The feed url is in the format: http://domain.tld/view?fetch=rss

    Can anyone verify if this would indeed cause problems and possible work arounds? Thanks

Viewing 15 replies - 1 through 15 (of 23 total)
  • How can we verify it when you don’t give it? 😉

    I don’t know if the “?” is a problem, but I’m having what may be a similar problem.

    I’m trying to redisplay a couple of feeds using WP 2.1 and the RSS widget. I’ve been using the feeds for months and haven’t really noticed any problem in other tools I’ve used to display them.

    What’s happening is that more than half the time I seem to get an error (“An error has occured; the feed is probably down. Try again later.”), but if I click the RSS icon used to subscribe to the feed, it comes up just fine.

    [Actually, I’m trying to display 4 feeds. Feeds 3 and 4 seem to be rock solid — just the first two seem to be having trouble.]

    This WP 2.1 installation is less than 24 hours old, so I don’t have a lot of history here. But if there’s something that might make the feed connections unreliable, I’d be interested to hear about it.

    In the meantime, maybe I’ll look into learning more about the widget architecture so I can do something other than treat them as a black box.

    Same problem here. I have a google news rss feed, and it seems as if the widget is stripping the last bit, &output=rss, from the address.

    At first I thought it was because I was switching between themes, but it persists as a problem. I am also having conflict issues between photopress and widgets.

    Anyone find a solution to this? I’m also having this problem when trying to get a feed from a path that has a question mark in it.

    I just installed WP, tested pocast plugin, worked first time. I really want to embed RSS feeds and was excited about the RSS widget.

    BUT .. it doesn’t work, and seems like it hasn’t in months.

    It also seems like it should be a really popular widget. Is anyone working on this?

    Do a google search for the error you see on your wordpress page where the RSS feed should be embedded:

    “An error has occured; the feed is probably down”

    It would appear a mere 28,000+ wordpress blogs on the internet are suffering this issue at the moment!

    joining in on those one. thought it could be the widget cannot handle https, but perhaps not?

    joining in on those one. thought it could be the widget cannot handle https, but perhaps not?

    just some additional facts. i’m hungarian so i have the windows-1250 characterset on my pc but i use utf-8 with my localhost installation of apache-mysql-php, including wordpress. the widget feeds are working just fine from my pc but do the same described mistake with the hungarian feeds on an internet server, actually at godaddy. the damned same installation. the funny part is that ultimate tag warrion is working just fine with my special character on the net but on my pc i can’t tag because of misreading my funny letters. so it must be a serious characterset mismatch problem. too bad…

    But yet not a single one of you can post a link so we can see what is occuring so we can try to solve the problem.

    the same described mistake with the hungarian feeds on an internet server

    És melyik az a “hungarian feed”, amelyik nem működ a “vidzsitben”? 🙂

    olá.
    hát ezeket próbáltam:
    http://kisherceg.blog.hu/rss2
    http://vg.hu/rss/kulfold.xml

    ez például köszöni, jól van:
    http://newsrss.bbc.co.uk/rss/newsonline_world_edition/front_page/rss.xml

    mondom, miközben lokálhoszton meg tök ugyanaz megy vidáman, ezekkel a feedekkel.

    1. kisherceg – tökéletes online blogban, utf-8 leosztással, mert a feed is utf-8.
    2. VG nem utf-8, hanem windows-1250, enélfogva soha nem fog jól működni egy utf-8 blogban.
    3. bbc szintén utf-8

    de nekem a kisherceg nem megy online blogban, a gépemen meg vidáman… meg a vg is, meg minden. őrület. a gépemen minden feed vidáman jön a netről, viszont a tag cloudban ő és ű helyett kérdőjek jelennek meg. a neten meg az utw is tökéletes. na mindegy, kösz a választ.

    Here is a link that doesn’t work for me in the RSS widget. All the URL’s with question marks in them don’t work. All other do (among the dozen or so I’ve tried).

    Not working:
    http://weblogs.macromedia.com/mxna/xml/rss.cfm?query=byCategory&languages=1&categoryId=2

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘RSS Widget Feed Problems’ is closed to new replies.