WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] RSS Widget Error

[Resolved] RSS Widget Error

Viewing 15 replies - 16 through 30 (of 35 total)
  • Hi Cafeman, thanks for the updated info, it’s much appreciated. I’m using Dotster to host my blog.

    I may be narrowing down this problem, and I believe it is related to the companies where we’re hosting WordPress. In my case, that’s aplus.net. I hope you can read this from the knowledge base of aplus.net: http://www.apluskb.com/scripts/I_have_a_shared_hosting_answer3264.html. At the bottom it says:

    Important: All outbound connections going off our shared hosting servers are filtered out by a firewall system. Our administrators review all requests for firewall changes per user basis. If you’d like to connect to a specific RSS feed, please file a request via email to support@aplus.net including the following information:

    * Your Account Registration Number
    * The Domain Name you’d like to use the RSS Feed on.
    * The exact URL of the RSS feed you’d like to connect to.

    This implies that aplus.net blocks all incoming feeds. A support representative, through their chat system, asked me for specific IP and Port numbers so he could open up their firewall from my shared server to these RSS feeds. When I asked “what if I want to change/add feeds later” he said I needed to specifically open up the IP/Ports for any feed I want, which means the functionality of my blog is less useful because I cannot do feeds. That’s another discussion.

    I didn’t know the IP addresses and Ports. Two of the feeds I want come from blogs I host at wordpress.com, and I haven’t thought of which others. But another one I wanted to try was the feed for this problem. So in a DOS window, I simply typed C> ping http://www.mycobalt.net and C> ping http://www.wordpress.org, and I got two IP addresses. In doing a google search, I found that the most common Port for RSS feeds is Port 80. So I gave him the two IP addresses and port 80. He says it should take a couple of hours and I’ll get an email.

    So I hope to be able to tell you something definitive today. Stay tuned…

    Hi guys: Aplus.net opened ports for my blogs on wordpress.com and to this post. I used IP addresses as I found them (using the method in the above post) and “guessed” on the port number being 80.

    Go to my blog http://yo.landyo.us and you’ll see that the RSS feed for MyCobalt, which is a blog hosted on wordpress.com, works like a charm. The other RSS feed, which is to this post, does not work. I believe the IP address is correct, but port 80 may not be the one used for these feeds. Don’t know.

    The point is this: WordPress software works fine. It is your hosting partner closing these links. You need to contact them and determine how to open up those ports for your “shared” server. If you’re on a dedicated server, then perhaps you can get them to open it up completely.

    The downside to this issue is that with any new RSS feed I want on my site, I have to have them open up the IP/Port to gain access. That severely limits my ability to add RSS feeds and I may decide to simply drop them altogether. Nonetheless, I believe we have solved this problem.

    Oops, quick update. The RSS feed for this discussion now appears on my blog, and so I suppose the port 80 for wordpress.org was accurately supplied to my hosting provider.

    Incidentally, I installed the “stats” plugin which requires an API key from wordpress.com. I had my hosting partner open a port to wordpress.com IP and port 80 – again, WORKS LIKE A CHARM!

    By the way, both the standard RSS Widget and KB Advanced Widget work.

    Cafeman, thank you thank you!

    I’m going to mark this resolved ’cause now at the very least we know ‘why’. We know what to do at our respective hosts.

    You sir, ROCK! 🙂

    Hey, thanks for figuring that out. (I’m the author of KB Advanced RSS.) I’ve been getting people asking why they get that “An error has occurred” message. Since I couldn’t replicate the problem, I just put that comment in the documentation (the comment you quoted earlier in this thread). I’ll update the documentation to point to this thread.

    Has anyone solved this issue for Lunarpages shared server hosting? Would appreciate some feedback on how to resolve this issue with them.

    I submitted a ticket to them about the opening of ports and I got a very generic response basically telling me it isn’t their problem. :\

    I guess they don’t care about losing the boatloads of clients I have referred.

    So if I understand this, I have to go to my hosting company, and ask them to allow individual RSS URl’s thru to my blog

    My host is 1and1.com….

    You got to be kidding!!

    Leo

    Sites that won’t give me unrestricted access to the Internet don’t get my business. That said, how dare they!

    It gets worse, my hosts are behind NAT on dynamic IP that changes every 20 hours. Yes, I use DynDNS.Org. A Firewall setup like that would completely shut me out. I will not go to static IP because it would make me vulnerable to DDOS.

    I’ve run into this problem before and then I realized it was my own stupidity.

    I have quite a few WordPress mu blogs hosted on the same host, ip, domain. I never ran into this problem until setting up a new WordPress mu installation.

    After receiving this error a few times: “Error: could not find an RSS or ATOM feed at that URL.” I finally realized I was unintentionally putting the ‘feed url’ in the RSS widget ‘title’ input field and I was putting the ‘feed title’ in the ‘rss feed url’ input field. Of course that would always produce and error.

    I just suggest you make sure you are putting the correct data into the correct fields…

    I’ve encountered this problem on a bash server I have root access to.

    Is there something I can change with bash or maybe php which would allow to allow wordpress to access feeds?

    Wish I could help, but I’m not having much luck here either. I don’t see this as being “resolved” either, as I’m using WP 2.3.2 freshly downloaded last week, and RSS feeds to my other WP blogs do NOT work.

    My first thought was a PHP config setting, allow_url_fopen, but I already have that set to “on”. So that’s not the issue. Our host does not use any firewalls that would block content, so that’s not the issue either.

    I have three WordPress blogs on the same server at our host, and I can’t link to any of them via RSS feeds. One is a “master” site from which the others spin off, so I like to put the most recent posts from the satellite sites on the home page in widgets.

    I cant’ link to other WordPress blogs, but I *can* successfully show feeds from forums on other servers (at other hosts) that I visit. And other news sites work. I have the Commentaries area of PC Magazine working in sidebar as well.

    One thing I noticed is that the WordPress feeds only show a directory name, where the forum RSS (or Atom) feeds point to actual files or script parameters. (BUT, PC Magazine’s feed is just a directory name, and it works!) It’s almost amusing that WordPress can’t find its own feeds. And yet, all of my WordPress feeds open fine in Feedreader, so they are indeed functional.

    If this is indeed a bug, it’s like WordPress is not succcessfully “hunting” its own feeds…as all other RSS feeds I’m trying in my sidebars are working.

    I’m not sure that this the solution. (firewall).
    There is a ver significant detail. When I change my theme the rss problem solves itself temporaly.
    ¿?¿?¿?

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘[Resolved] RSS Widget Error’ is closed to new replies.
Skip to toolbar