Support » How-To and Troubleshooting » RSS widget doesnt work after WP 2.5.1 upgrade

RSS widget doesnt work after WP 2.5.1 upgrade

Viewing 8 replies - 1 through 8 (of 8 total)
  • Anyone? Please help

    2.5.1 didn’t break it if you were running 2.5 before. The rss.php has not changed in over 4 months:

    i have the same problem… help!

    could it be my plugins? or … something? i have two blogs – both on fantastico – one upgraded perfectly fine but one doesn’t!

    I still get the same error, especially with the feedburner feeds ONLY ….

    Here is the error:
    Warning: Attempt to assign property of non-object in [path]/blog/wp-includes/rss.php on line 440

    I had this problem too and I tracked it down to the serialize / unserialize code in rss.php. For some feeds, it appears that the serialized objects are corrupted during the mysql roundtrip (not entirely sure why?) and the quick solution is to base64 encode and decode the serialized objects as they pass in and out of mysql via updateOption and getOption. My fix is available via github if anyone is interested. It also fixes up some of the broken attempts to write out debug messages in the RSSCache.


    I followed this through and all seems great now.

    Many , Many thanks.

    I thought the problem had gone away then I just upgraded to wordpress version 2.6.3. and the problem appeared again so have implemented

    @peterhw, you’re not alone. I’m encountering the same error as well. I’m going to hunt around the forums and see what I can find. If I turn up anything I’ll post it here.

    @blowery, thanks for the fix and it did the trick.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘RSS widget doesnt work after WP 2.5.1 upgrade’ is closed to new replies.
Skip to toolbar