WordPress.org

Forums

RSS Syndicate Feed Not working (8 posts)

  1. tbiaslorin
    Member
    Posted 5 years ago #

    Ma'am/Sirs,

    I am having problems getting my RSS feed to work correctly in all browser's. For some reason, it works in Firefox on both mine and a friend's computer, but not on any version of IE that I can find. I have tried it on 2 XP pc's, one Vista laptop, and for fun, with Safari on my iPhone (I am not very computer literate, so I don't know if iPhones can use RSS). Also, when I link to it on a site that would show a current blog post in my user profile, it links an error instead.

    My site is:
    http://www.adviceandbeans.com (Yashfa theme)
    Mr RSS2 feed is:
    http://adviceandbeans.com/?feed=rss2
    Link validator says:
    line 60, column 0: XML parsing error: <unknown>:61:0: not well-formed (invalid token)
    Line 60 says:
    </rss>

    I get the same thing for http://adviceandbeans.com/?feed=rss as well, just on line 27. Ditto with Atom and the other one I think.

    Any help would be greatly appreciated!

    Thank you!

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    RSS feeds are not meant to read via a web browser.

  3. tbiaslorin
    Member
    Posted 5 years ago #

    I understand. However, when I use Foxfire to click an RSS link, it takes me to a page that lets me pick some information about the feed. In IE I can click the RSS button on many pages and it either shows some information or a bunch of XML. For example, when I click the RSS button below on this site, it does exactly that.

    However, when I use IE and click RSS on my site, it doesn't display anything, and just errors out. When I plug the feed into a place where it is supposed to do something, it shows an error. For example, I use a forum where you can plug in your RSS feed and on your profile it shows your latest blog post title. When I use my feed there it links to an error code, not a blog post.

    Additionally, when I use a site that validates RSS feeds, it generates the error I listed above and says the feed is incorrect.

    Thanks!

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Line 60 of your RSS feed:

    * original ('./wp-blog-header.php')

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

  5. tbiaslorin
    Member
    Posted 5 years ago #

    I tried the switching the theme, though that did not help. I will go try the plugin thing now.

    original ('./wp-blog-header.php')

    I saw that line in the link validator, and I am trying to find the text file that contains that line, to no luck so far. Is it possible that deleting that line would fix the problem, as the software doesn't understand what it says?

    Thanks!

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    It does need to be removed but it's probably coming from a plugin. Looks like something that was possibly intended to be used on a site with a integrated WP blog.

  7. tbiaslorin
    Member
    Posted 5 years ago #

    Ugg, I'm a dodo, thank you for your help.

    I actually changed that line in the index.php. I've been learning Visual basic, and I thought the * symbol was the same as a ' in VB, meaning it allows comments that have nothing to do with the code. So I put that line in ('original' meaning that line was the way it looked before I did anything to it) to let myself know how to fix it if I broke something. Well, back then I was trying to fix my blog because I moved it out of its default folder, so I didn't realize it might affect something else like the RSS feed.

    That's what happens when us newbies start fooling around!

    Thank you and my apologies for causing my own problem!=)

  8. esmi
    Forum Moderator
    Posted 5 years ago #

    No probs. Sometimes all it takes is another pair of eyes. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic