Support » Fixing WordPress » RSS returns ERROR 403

  • Resolved guyshomenet

    (@guyshomenet)


    I have no idea when the problem started (which upgrade) but my RSS feed has died. Need to get a fix soon.

    SYMPTOMS:

    1) Main RSS2 feed (http://www.siliconstrat.com/blog/feed/) produces the 403 error

    2) The comment RSS feed (http://www.siliconstrat.com/blog/comments/feed/) does not.

    Using (I think) standard syntax in the template sidebar file:

    <li>
    <a>" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?>
    </a></li>
    <li>
    <a>" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?>
    </a></li>

    [Please post code & markup between backticks or use the code button. Your posted code has been permanently damaged by the forum’s parser.]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Was getting a 403

    Do you know the difference between 403 and 404?

    404 = missing file/page
    403 = forbidden to access due to settings on the server.

    what should their permissions be?

    Files should normally be 644 and folders 755.

    @esmi

    Hmmm. What chin to modify. There is no /feed directory nor the aforementioned rss/index_rss2.xml, so there is nothing to modify (assuming it is a redirect). What dirs/files need chmod?

    your 403 error may be related to security settings on the server – not anything to do with file permissions. We’ve seen a big increases in server security related issues here as as result of the recent mass attacks. Yours may be one of these, Try contacting them about it.

    @esmi

    Some folks don’t read threads ;->

    Two separate WP blogs on the same server — one works, one doesn’t. Both using the same server/settings. All other WP functions working well even on the one with the bad feed.

    There really wasn’t any need for that comment. I have read the whole thread a number of times. And this could still be a server security issue. You really do need to check with your hosts about it.

    RESOLVED:

    Given lighter weekend traffic I tried a few Hail Mary plays including

    • Auto update
    • Theme tweaks
    • Manual update and finally …
    • A cold install from scratch (purge entire blog directory), hand copying in enhancements
    • That last one did it, removing whatever funkydo was left over from prior WP versions. Up until now the standard WP updates have worked fine (both auto and the manual), so I don’t know what error was induced on this site. For previous version I had done both auto and manual for this particular site, so I suspect one missing error check in an earlier auto-update (but that is pure speculation).

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘RSS returns ERROR 403’ is closed to new replies.