WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] RSS returns ERROR 403

[Resolved] RSS returns ERROR 403

  • guyshomenet
    Member

    @guyshomenet

    I have no idea when the problem started (which upgrade) but my RSS feed has died. Need to get a fix soon.

    SYMPTOMS:

    1) Main RSS2 feed (http://www.siliconstrat.com/blog/feed/) produces the 403 error

    2) The comment RSS feed (http://www.siliconstrat.com/blog/comments/feed/) does not.

    Using (I think) standard syntax in the template sidebar file:

    <li>
    <a>" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?>
    </a></li>
    <li>
    <a>" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?>
    </a></li>

    [Please post code & markup between backticks or use the code button. Your posted code has been permanently damaged by the forum’s parser.]

Viewing 15 replies - 1 through 15 (of 23 total)
  • esmi
    Forum Moderator

    @esmi

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    guyshomenet
    Member

    @guyshomenet

    None of the suggestion (all tried in various ways over various upgrade) explain why the comment feed works but the rss2 and atom feeds do not.

    esmi
    Forum Moderator

    @esmi

    Did you try any of those steps now?

    guyshomenet
    Member

    @guyshomenet

    Yep. The most basic, switching back to default theme … nada.

    The recent upgrade (about a month or two ago) was a fresh download upgrade.

    Now, during that upgrade, I did disable/enable all plugins for a different problem … have not tried for this one as I’m waiting for diagnostics and/or explanation of the comment/feed differentiation (too many years in IT has taught me not to chase ghosts).

    Resting folder instruction made no sense.

    esmi
    Forum Moderator

    @esmi

    You really need to try all of the steps listed above. There is no magic bullet in these situations. This is just the start of basic troubleshooting and is a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    guyshomenet
    Member

    @guyshomenet

    Deactivating plugins … nada.
    Themes … nada.
    Fresh load … already done.
    Resetting plugins folder … description of process lacks specificity.

    esmi
    Forum Moderator

    @esmi

    In what way does it “lack specificity”?

    guyshomenet
    Member

    @guyshomenet

    Sorry. Buried in the link provided. Renaming ‘plugins’ … nada.

    esmi
    Forum Moderator

    @esmi

    Many hosts are currently experiencing problems due to mass attacks. Yours may be one of them. Try contacting them.

    guyshomenet
    Member

    @guyshomenet

    Nope, not the issue.

    “Error 403” … only occuring on rss2 and atom feeds. The rest of the site is humming along. Seems to be a bug in WP redirect (since there is no /feed directory). I’ll note that the altenate feed link (http://www.siliconstrat.com/blog/?feed=rss2) redirects to /blog/feed/ and produces the same error.

    guyshomenet
    Member

    @guyshomenet

    Addendum: I have a different blog under a different domain on the same server and using the same WP version (and most of the same plugins). The RSS feed works fine there.

    So, having eliminated themes, plugins and install files, where else might the problem reside?

    esmi
    Forum Moderator

    @esmi

    Seems to be a bug in WP redirect (since there is no /feed directory)

    No – it’s not a bug. The feed is generated on demand with a url based upon whether you are using custom permalinks or not. Have you spoken to your hosts about this. Error 403 suggests that permissions have been changed on that site.

    bottleneck
    Member

    @bottleneck

    @guyshomenet

    do you really get 403?

    Your feed returns 404 on my side.

    guyshomenet
    Member

    @guyshomenet

    Was getting a 403, but I started comparing my two separate blog sites and noticed an oddity here. There was a soft link (feed -> rss/index_rss2.xml) in the bad site that wasn’t in the good site. As an experiment, I renamed it given that there was no rss/index_rss2.xml file.

    I’ have renamed it back for the time being.

    guyshomenet
    Member

    @guyshomenet

    @esmi

    Let’s roll with this suggestion. files/directories would be affected and what should their permissions be? Snap to chmod them if I know which ones to tweak.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] RSS returns ERROR 403’ is closed to new replies.