Support » Fixing WordPress » RSS Reader won’t show full content of blog post

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    (@esmi)

    Forum Moderator

    Your RSS feed is fine – especially when you take into account that your posts don’t contain that much text. The display issues you’re seeing relate to display settings for those RSS readers rather than anything in WordPress.

    What reader did you test it in? It shows only a summary in my netnewswire reader, and google reader. your reader is showing the full images and text?

    i tried unsubscribing, and resubscribing, and it still didn’t work.

    esmi

    (@esmi)

    Forum Moderator

    Sorry – I used Firefox 3 so I didn’t see the images. But I also checked the underlying code of the RSS output and it does include images.

    So has anyone actually tested it in a reader? Am i the chosen one in wordpress land that doesn’t get full content output to an RSS reader?

    esmi

    (@esmi)

    Forum Moderator

    The full content is being output from what I could see in the source code of the RSS feed. For example

    <content:encoded><![CDATA[<p>I had a fun Halloween.  My band did 4 Black Flag cover sets in 3 days.  </p>
    <p>We played Seesquat with Hunky Punkz.<br />
    <a href="http://www.flickr.com/photos/socialpurgatory/4072387968/" title="hunky punkz by Blake Sinclair, on Flickr"><img src="http://farm3.static.flickr.com/2494/4072387968_f193c9b2be.jpg" width="375" height="500" alt="hunky punkz" /></a><br />
    <i>Hunky Punkz by me.</i></p>
    <p>And Wreckroom with Concussions and a Murder City Devils cover band.<br />
    <img src="http://farm3.static.flickr.com/2472/4072174288_3c01907afb.jpg"><br />
    <i>Black Rats by <a href="http://www.jbeckerphoto.com" target="_blank">Jenn</a></i></p>
    <p>After a month of practicing only Black Flag, I’ll be happy to start writing original stuff again.</p>
    ]]></content:encoded>

    I have seen this problem over and over with no solution, except everyone from WP saying “it’s fine!” and a lot of users saying it doesn’t work. I have “full” selected in my reading settings, and in Google Reader (in Chrome as well as FF) I get truncated feeds. Turned off feedburner, uninstalled related plugins, same thing. All my readers say the same thing, wondering why I won’t publish a full feed – to which I can only reply “I’d like to.”

    http://x.superbadgirl.com/blog is my blog’s address, and any help other than “it’s not broken” would be much appreciated. Obviously there is SOME issue, if it’s broken for me and everyone else trying to read it.

    Moderator James Huff

    (@macmanx)

    http://x.superbadgirl.com/blog/feed

    Your feed is working perfectly, it’s displaying full content, and it’s perfectly valid:

    http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fx.superbadgirl.com%2Fblog%2Ffeed

    There is one warning regarding the embedded Youtube video, but it’s quite common and shouldn’t break anything.

    Honestly, there’s nothing more to say besides “it’s not broken.”

    I am facing this problem for last one week. My blog is – http://www.bookmyroomz.com/blog/

    It was working fine till last week, and now the feed is showing only 1 line (the first line of the content). And I have tested it over all readers / browsers, but no use. 🙁

    I would request your help.

    Thanks,

    Raj

    I am facing this problem for last one week. My blog is – http://www.bookmyroomz.com/blog/

    It was working fine till last week, and now the feed is showing only 1 line (the first line of the content). And I have tested it over all readers / browsers, but no use. 🙁

    I would request your help.

    I was able to resolve it by – changing the Feedburner Plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘RSS Reader won’t show full content of blog post’ is closed to new replies.