Support » Fixing WordPress » RSS question re WP via midPhase

  • I added WordPress to my site via my host, midPhase. Everything seems to work ok except I can’t figure out how to get the RSS feed to work. It’s listed on the links in the template I’m using, but it doesn’t look like there’s anything there to ping. Looking for some help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • When I look at your feed it doesn’t appear to be pointing to the wp-rss2.php but just pointing to the overall directory into which your blog is installed. Right now it appears to look like this: But when I change it to then tests and passes it as a valid feed. If this is the problem, then the solution may be to edit the RSS link in your sidebar.php file of the theme you’re using to the one I tried above. Hope this helps.

    Makes sense, but I don’t know PHP (yet) and there’s obviously a different means of rendering that url in the sidebar.php than the way I’m used to with regular XHTML.

    The original code in the template looks like this
    ” title=”<?php _e(‘Syndicate this site using RSS’); ?>”><?php _e(‘RSS’); ?>

    If I replace ‘rss2_url’ with ‘wp-rss2.php’, the problem remains. So how do I code the correct url here? I also tried entering the entire url ‘’ and it didn’t work that way either.

    Can you help me with this?

    Well that url obviously didn’t take the pre tag. but the url is indicated in parentheses as ‘rss2_url’. I’m assuming that this is where I need to change whatever needs to be changed. Right?

    NOTE: IF macmanx is perusing the forum, please jump in. He helped me greatly with this issue and knows a LOT more than I..

    Since I’m also a WP/Midphase user and have struggled with the RSS issue I’m taking a whack at returning the help I’ve received. That’s just a disclaimer that I’m no expert but extremely empathetic.

    The first thing I learned is just because I can’t see it, the feed is actually working, believe it or not. For instance, if you enter in a newsreader such as Pluck or in a service such as MyYahoo or Bloglines you’ll see a successful reading of your feed. In fact, when you run the above through you’ll not only get a successful validation of your feed, but they will provide you a snippet of code and an icon you can place in your sidebar that will allow you to directly test your feed any time by just clicking the icon. (Example on my own blog at as at the bottom of the sidebar.)

    So the emotionally comforting news is that the feed is working.

    I’m thinking since your feed returns:

    and my feed returns:

    that the issue may be you’re using permalinks and I’m not? I hope this helps a little and someone else will jump in if this is the wrong direction.

    Thanks, Servant. The feed does indeed work. I’ve added a syndication category in the regular links until I can figure out how to work the php to edit the template a little better.

    I don’t have any permalinks. I got a message saying if I wanted to use them I’d have to add something to my .htaccess file. And I don’t know how to do that. I couldn’t download it to even see what it looks like. Maybe it’s because I’m using Mac Panther OS???

    I still can’t figure out how to get a graphic link in the designated spot in the template. I see you’ve done some customizing in the template you’re using. How did you get the ‘add to my…’ buttons onto your site? I’ve tried using the form screens via my WP account, but haven’t been able to get any images to take after I’ve entered them.

    Also wondering how you added your custom image to the top of the template. Are you reconfiguring the index.php file?

    Thanks for whatever help you can give.

    You have permalinks on and you haven’t edited htaccess which is why your post links, rss links etc are 404.

    To see .htaccess, make sure your FTP client is set to show hidden files, and if it’s still not there, make a file called “.htaccess” and put in the the directory /weblog. Edit it as a normal text file.

    And yeah, to edit the outputted page’s html you’ll need to edit index.php… you can add stuff to it just like you would in html, just be careful to add html outside the <?php ?> parts.

    As a midphase customer, you can edit any file via your cpanel web interface. (Although I prefer to use Adobe GoLive.) Log onto cpanel and then select “File Manager” under “Files”. The File Manager will appear showing a crude directory tree. The files you want will all be under the “public_html” directory so click on that. This will show the files and directories in your web site. In your case, you’ve installed WordPress to a directory called “weblog” which you should see at this point. (You should also see the file “.htaccess” at this point for future reference.)

    Once in your “weblog” directory you can browse around and eventually find just about any file mentioned in this forum or in regards to WordPress. But the main files for whatever theme you’re using will be located under the “wp-content” directory, then the “themes” directory under that, then under a directory probably named after the theme you’re using. (Example: wp-content\themes\classic) Once there, you’ll see the main files such as “index.php”, “sidebar.php”, etc. that are used. (This is all good to learn any way in case you ever need to make a quick change to your web site and aren’t sitting in front of your main computer.)

    Clicking on a file such as “sidebar.php” brings up a menu in the top right-hand corner of the browser. If you then click on “Edit File” it will open up “sidebar.php” in a window where you can make changes and then save the file. (The WP Codex has excellent examples of how the code works and all the possible alternatives.)

    If you know anything about HTML, the sidebar.php file will start to make sense. You’ll see by example how to insert, copy, change things. It’s not a bad idea to load a few other themes even if you don’t actually use them, just to look at their code.

    In the theme I downloaded from someone else, the index.php called for an image for the header. I made another the same size and saved it to the theme directory with the same name. And so with many other tweaks and amendments. The subscribe buttons and code were all supplied by a wonderful WP plugin called “Subscribe Me” that I highly recommend.

    Sorry this is so long, hope this helps.

    Servant, you’re truly generous sharing your time and knowledge. I think perhaps I’m coming across dumber than I am, however.

    Though I’m not a programmer, I am a designer. I create, design and edit websites with HTML and XHTML with CSS using BBEdit. I’ve pulled all the files in the template directory into BBEdit and have experimented with applying code on the index.php, but I obviously am not intuiting PHP structure or rules very well because nothing I’ve done has given me the results I’m looking for. Downloading a few other templates and looking over the code may indeed help. Thanks for the suggestion.

    Where does one find this “Subscribe Me” plugin? The only plugins I’ve found are Hello Dolly, Markdown, and Textile 1.

    An .htaccess file is visible in my FTP client for my host directory, so I assume such files would also be visible throughout. That said, none is visible in my wp-content directory nor in my template directory. When I ask Fetch to show all files it tells me there is no such file there. When I try to create a .htaccess file, my operating system refuses to make it visible. “Files beginning with a dot are reserved for the system.” And files I’ve created beginning with a dot, in spite of the warning, won’t show up in a system search. If you know how to find these invisibles on Mac OS X 10.3.9 please tell me how.

    Thanks to both of you for your help.

    Lydia, with Cpanel you can go to file manager and create a file inside the relevant folder – then you name it .htaccess and edit it in file manager. It’s hard to grab something in an ftp client where you can’t even see the darn thing! Check in the options for your ftp client too – there’s usually some way to see the “invisibles”. For instance in WS_FTP Pro, there’s a little blank box in the side panel which is for “file masking” – you enter the . there and get to see the files which start with it – .htaccess, .htpasswd, etc.

    Thanks, vkaryl. That worked. I’m so used to creating files on my desktop and FTPing them to the server, going through file manager seemed unneccessary. Turned out to be the way to go with this file.

    I can see .htaccess files in my FTP client without a problem. Fetch isn’t the problem. It’s my operating system that won’t let me see them to create or edit them like I do all my other files. So downloading a file beginning with a dot is useless. It disappears as soon as it hits the desktop!

    But there was no .htaccess file in the template directory to deal with anyway. I used the code offered at WordPress on the Permalink page to create it new — in the file manager as you suggested. That worked.

    Now that I have the permalink working, I have to learn how to work my way around a php file.

    Thanks for your help!

    You’re very welcome! See what comes of never having used anything but DOs and then Windows…. I had no idea that an OS would prevent that sort of thing!

    Yeah, my definition of “user friendly” is whatever you know. Once knowledge is attained it automatically becomes “user friendly.” 😉

    Subscribe Me can be found at

    Good definition, Servant. Kinda similar to my definition of “common sense” – whatever I know that you don’t that I think you ought to know — or vice versa, of course.

    I expect if I knew a little more about UNIX commands there’s probably a way to make those files beginning with dots visible. But, like I said, I’m not a programmer.

    Thanks to all for your kind help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘RSS question re WP via midPhase’ is closed to new replies.