Support » Requests and Feedback » [Resolved] RSS Problem in WordPress 2.2

[Resolved] RSS Problem in WordPress 2.2

  • I upgrade to 2.2 and since that I lose my feed, when I try to validate it give me this error:

    <em>XML parsing error: <unknown>:3:0: xml declaration not at start of external entity </em>

    My feed in feed burner look like this:

    feed masmenosuno.com

    feed comments masmenosuno.com

    I uploaded wp-includes again without any result.

    I’ve try desactivate all plugins searching the error and nothing.

    I’ve check the code looking for a space in the plugins but everythig is ok but my feed.

    My website is http://www.masmenosuno.com, please I need some help or I will be forced to do a ritual sacrifice 🙂


Viewing 15 replies - 1 through 15 (of 27 total)
  • I am still using WordPress 2.1 but after installing FeedBurner I got a similar error when trying to validate:

    line 2, column 0: XML parsing error: <unknown>:2:0:
    xml declaration not at start of external entity

    Hopefully both of our problems can be fixed in this post

    My website is http://myagoraphobia.com/


    Can someboydy help me? I’ve got a goat ready for the sacrifice, Her name is Chichi, Help it! Save Chichi´s live with a hint of what´s hell is happening with my feed.


    PS.- Chichi is caramel color and cute

    I got a burned a feed through feed burner and it worked fine until a couple of days ago. I was using the feed locations plugin and it worked for a day then I just got a lot of gibberish when I clicked on any of the feed links on my site. I went to feed burner to check and it said my feed was invalid. I deleted my feed burner feeds in an attempt to go back to my original feeds and it was no good. I don’t have any idea what could have happened.

    I’ve notice my problem began when a change my server from godaddy to dreamhost. Maybe the problem is in the server.

    Can this be true?

    PS.- Chichi is alvive… yet

    I copied my blog over to a different directory on my server, and the rss fee works fine. I tried to leave the files in the new directory and link still have the blog located in the root of the website per these instructions. Everything worked except the Comment RSS feed. Not sure if that helps figure out what the problem is.

    @sitoxic – your feed starts with multiple blank lines. That’s bad.

    Odds are, if you disable plugins that’ll be cured. So, go through each plugin.
    Anything before the top <?php must be removed.
    Anything after the last ?> must be removed.

    See if that helps — and good lord, save that goat!

    @ruby – you have some sort of redirection thing going on from www to no-www that seems to be hosing things up.

    I am using feed burner for my feeds and I was using the Feedsmith plugin to redirect my feeds. While trying to fix my problem I ran across this walkthrough for redirecting your WordPress Themes to Feedburner by editing your .htaccess file. So I updated the .htaccess file and my comment RSS was still returning an error. I found another site (I forgot to bookmark it) That suggested using fancy permalinks. So I went into WordPress Options and chose “Date and Name Based” Permalinks. And my links went to FeedBurner, and they worked. I tried restoring my old .htaccess file using the new permalink and I got the same error, and I tried just using the .htaccess edit without the Permalink change and I also got the error. It is something about these two things together (plus feedburner) that fixed my problem. I’m not much of a programer but I know I’ve just found a band-aid. I hope this helps you guys find the root of the problem, it seems to be happening a lot in 2.2.

    I’ve tried all of that but I get no solution, with all the pluggins off the problem continues.

    I’m totally lost

    PS.- Chichi seems to have a dark future

    Don’t feel bad my fix didn’t last long. But I do have it working now. I got The Feed Locations Plugin and redirected my feeds directly to the associated .php file on my server. I also changed the WordPress URL and Blog URL in the WordPress options to http://www… instead of just http://… And now all of my RSS feeds work. I don’t think the www change had anything to do with it because I changed it back and it still worked. Also I backed up my data base and completely reinstalled everything. (I’ve only got 30 posts or something so that’s probably less of a hassle for me then it would be for you.) I’m not sure if that helped. It still didn’t work after I’d done it. It was only after I used the Feed Locations Plugin.

    Good Luck Chichi!

    I’ve tried all of that but I get no solution, with all the pluggins off the problem continues.

    Ok… check wp-config.php as well. Does your theme have a functions.php? check it. Heck, try changing to Default theme just for grins — does that change the problem?

    HandySolo thank you very much, it was the fuction.php, the f*cking fuction.php.

    Thanks again

    You has made Chichi the happier goat in the world XD

    No dice.

    Deactivated all plugins and checked the K2 functions.php and wp-config.php.

    There’s nothing in before <?php and not even whitespace after ?>. Are there more things I should check for?

    I still get:


    This feed does not validate.


    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    <?xml version=”1.0″ encoding=”UTF-8″?>

    In addition, this feed has an issue that may cause problems for some users. We recommend fixing this issue.


    Feeds should not be served with the “text/html” media type

    when trying to validate the rss feed.

    That’s pretty uncool.

    I have had similar problems myself with the feeds from a few blogs I maintain, and have seen similar problems with others feeds after updating to the latest version. The problem seems to come and go with no obvious reason why. When the problem is there, there is whitespace above the first line of code in the feed. Then other times there’s no whitespace and it seems to be fine.

    I gave up trying to get it for a while as I was tearing my hair out 🙁
    I have tried all the above variations and I can still not get it to work.
    I have installed the Feed Locations plugin and I’m using Feedburner and neither have sorted the problem.
    When they are installed I can’t get to my feed page from the meta link, once the plugins are deactivated then I can get to feed page

    I think I will never get a feed going, it is so frutstrating.


Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] RSS Problem in WordPress 2.2’ is closed to new replies.
Skip to toolbar