rss problem again; what is missing here? (7 posts)

  1. slodaddy
    Posted 9 years ago #

    I keep getting an error on my rss feed (which was working well last week) that states xml parsing instructions missing on line 2. What is wrong with line 2?
    '<?xml version="1.0" encoding="UTF-8"?>'

  2. URL please...

  3. slodaddy
    Posted 9 years ago #

  4. That's not a problem with line 2, it's a problem with the blank line 1. What you're seeing is commonly a plugin issue. Disable all active plugins and check your feed's validation again.


  5. slodaddy
    Posted 9 years ago #

    Thanks, macmanx. The theme switcher is the only plugin I have been using. I don't understand why it works sometimes, and other times it dinks up the rss. Is the plugin the real problem? Or is it my database or something else? I tinker with the themes frequently, but my feed link and the theme swithcer plugin have been untouched since I first installed wp a few of weeks ago. Regardless, that solved my problem and I am very grateful for your help and quick response. The WP support team is the bees knees.

  6. Not a problem, I'm glad to be of service. You might want to check the themeswitcher plugin file. There may be a blank line at the top of that file. If there is, delete the blank line, and your problems should be solved.

  7. Frobenius
    Posted 9 years ago #

    We are having the same exact problem with out wp build. The RSS feed's XML begins with a spurious blank line. It's not the themes and it's not the plugins. Here is a big clue (and this just might help some other WordPress sites) - If the rss2 php module is called directly, like so:


    ....there is no blank line in the generated XML.

    But if the link to the RSS feed uses the " bloginfo('rss2_url'); " link generator, like this:


    ...a blank line is generated. If the link did not have the trailing slash, like so:


    ...no blank line.

    So ... what's really happening here? It's something to do with the permalinks! I have traced the code to the get_feed_link function in wp-includes/template-functions-links.php. Something in that code generates an extra slash, but I'm not a php expert. Maybe it depends on how a site has configured the permalink settings. Perhaps someone else could have a look at this and figure it out?

    Removing the permalink settings solves the problem, of course, but who wants to do that?

Topic Closed

This topic has been closed to new replies.

About this Topic