WordPress.org

Forums

RSS problem (25 posts)

  1. sharonb
    Member
    Posted 10 years ago #

    total newbie here - who is having real trouble getting my head around some of this
    I have trawled around for a couple of days trying to figure this out
    when I click on RSS 2.0 link and comments RSS 2.0 link i get an error
    "Not Found
    The requested URL /blog/feed/rss2/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "
    if I try and access
    http://www.inaminuteago.com/blog/wp-rss2.php
    I can see it
    after searching the support forums I thought it might be the htaccess file - but I could be wrong because I am not sure about any of this stuff
    If I ftp to the site I can see a htaccess file in my public_html directory but not one in the 'blog' folder
    If I try to edit it through WordPress interface I get
    Editing .htaccess
    Oops, no such file exists! Double check the name and try again, merci.
    The Question is - do i have to create a htaccess file to solve this problem - if so how? Or am I going off in a wrong direction -
    I seem to have been mucking about with this blog for weeks (transfering from Typepad) any help out there would be most appreciated - as I say I am a newbie at this

  2. sharonb
    Member
    Posted 10 years ago #

    Thanks for the quick reply - I tried it but I still get the same error - would the output from the options | permalinks posted here help anyone?

  3. sharonb
    Member
    Posted 10 years ago #

    sorry to post again - the fact that I had the permalinks working - but not the RSS confuses me no end - and there wasn't a htaccess file until I created one - so I am still scratching my head... have learnt heaps along the way though

  4. sharonb
    Member
    Posted 10 years ago #

    just tried it and now i have lost my permalinks ...

  5. Beel
    Member
    Posted 10 years ago #

    You have to then copy the new output into the htaccess file.

  6. sharonb
    Member
    Posted 10 years ago #

    I did - and thats when I lost the perma links and still the same error for rss -
    do you want to see the output here?
    I am poking around your blog...

  7. Beel
    Member
    Posted 10 years ago #

    Nah, won't help. If you put in the suggested structure, hit update and then copied the result into .htaccess and ftp'd it into your blog directory that should be it.

  8. sharonb
    Member
    Posted 10 years ago #

    yep I did that - but I will try again incase I did something dumb -

  9. Beel
    Member
    Posted 10 years ago #

    I use:
    /archives/%year%/%monthnum%/%day%/%postname%/
    and
    /archives/category

  10. sharonb
    Member
    Posted 10 years ago #

    yes I just tried it again - with your structure - and it did not work -
    just to make sure we are not talking at cross purposes (as i am new to this stuff) I am looking at options \permalinks towards the bottom
    the /archives etc is in a box just above the update permalink structure button - I click that
    select all the text that is generated
    paste it inot the htaccess file and ftp it to my blog site
    am I doing right?

  11. sharonb
    Member
    Posted 10 years ago #

    yes "RewriteEngine On" and is in the blog directory
    I have had a lot of problems really - have to go now its knock off time in OZ - what is it over there? will check back in later on tonight and see if you have come up with some magic -
    I am wondering if I should just start over again ... I have had alot of glitches over the past few weeks trying to set this up

  12. sharonb
    Member
    Posted 10 years ago #

    I have just put back the index.php in the permalink -
    just thought I would try it
    and permalinks and the RSS now working - so something kicked in but i don't really know what - would love to know if anyone has any insights that I can understand!
    thanks Beel for your help something in all that cleaned up the error.

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    I have had the same problem - rss link gave the 404 error as soon as I enabled permalinks using the '/index.php/' structure for permalinks (i.e. no need for .htaccess file). Permalinks worked fine after that but then the rss link generated the 404 error. I disabled permalinks and the rss feed started to work again. Maybe I have to figure out the .htaccess approach to permalinks in order to get both permalinks and rss working

  14. carab
    Member
    Posted 10 years ago #

    Hi,
    did everything as supposed, but as soon as I upload .htaccess /(as Ascii)
    my server tells me:
    ' Forbidden
    You don't have permission to access / on this server.'
    I use a standart LAMP -System.
    Blog-dir is root
    CAn you help?

  15. Have you contacted your hosting provider?

  16. carab
    Member
    Posted 10 years ago #

    I am using serveral .htaccess- Files. When I delete the .htaccess file with the lines from options /permalinks, everything is fine.
    Here my .htaccess:
    '
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php/archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/category/?(.*) /index.php?category_name=$1 [QSA]
    RewriteRule ^index.php/archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/author/?(.*) /index.php?author_name=$1 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&withcomments=1 [QSA]
    '
    Is there a conflict with my apache configuration? Or just a bug in those lines

  17. You can only use one .htaccess file per directory. If you all ready have a .htaccess file in that directory, then you need to add the rewrite code to it.

  18. carab
    Member
    Posted 10 years ago #

    Nope, that s not it.
    Same host, but different virtual server/domains...
    No problem, it I upload a .htaccess containing
    DirectoryIndex index.php index.htm index.html
    if I chmod 666 .htaccess
    and open this within the online template editor , insert the text from options /permalinks and press "Update file" i get
    Forbidden
    You don't have permission to access /wp-admin/templates.php on this server.

    right away. Then I have to
    rm .htaccess
    to make the blog accessible again.
    I am lost....

  19. According to any reputable webdesign forum and tutorial, .htaccess should be CHMOD 644 to prevent browsers and external programs from directly accessing it (presenting it in a viewable fashion, thus compromising password-protected directories). Even though WordPress says that it can only access files with CHMOD 666, it can access other files with other CHMOD values as well, such as 644, 777, and 755. Try CHMODing your .htaccess file to 644, see if that has any impact.

  20. carab
    Member
    Posted 10 years ago #

    Dosnt make sense, because all other value are IMHO more restrictive then 666 (hell, it _the_ numer), but I will try it anyway.
    But the blog ist working still after 666ing it, it only stops wenn I insert those lines from options /permalinks and press "Update file"
    So I gess it has to be something in this lines...

  21. carab
    Member
    Posted 10 years ago #

    644 - You cannot update the file/template
    777
    -> Forbidden
    You don't have permission to access /wp-admin/templates.php on this server.
    755 - You cannot update the file/template
    Then I changed .htaccess offline, uploaded and then chmod-ed it to all of those numbers: ->
    403 Forbidden
    You don't have permission to access / on this server.
    Apache/1.3.26 Server at www.nanoperium.de Port 80

    empty .htaccess uploaded -> everything works fine
    How do I grant all users access to a site using .htaccess (in the literature and web i find only examples how to restrict access)?
    Maybe that would help

  22. carab
    Member
    Posted 10 years ago #

    @Kafkaesqui:
    did it (even tried multi), doesnt work: ->
    Forbidden
    You don't have permission to access /index.php on this server.
    Apache/1.3.26 Server at http://www.nanoperium.de Port 80
    What is it in those lines that closes my server?

  23. carab
    Member
    Posted 10 years ago #

    Me again.
    Is it possible, that mod_rewrite is not running on my server ?
    How can I check?

  24. carab
    Member
    Posted 10 years ago #

    >Ask the admin? ;)
    For non-profit projects I have to be the admin myself, I am running the damnd server - so I trying to understand what I am doing. :-(
    >RewriteEngine On
    >RewriteRule ^test.php /test2.php [L]
    Doesnt work neither.
    Well now I have to find out, how to make mod_rewrite running. I just dont get, why it blocks access, instead of throwing an reasonable error. I mean, its linux, not windows, right?

  25. carab
    Member
    Posted 10 years ago #

    Problem solved, RSS is running.

    If you ever happen to have a problem with modrewrite, you might find the solution here (as i did):

    http://www.modrewrite.de/foren/ftopic82.html

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.