WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] RSS not working. XML parsing error.

[Resolved] RSS not working. XML parsing error.

  • Hello everyone.

    I have put A LOT of work into my WordPress for my church, and I have discovered that RSS feeds do not work. I can subscribe and view them in dedicated RSS readers and Firefox but things like IE, Safari, Chrome, Mobile Safari cannot read it. I tried using Feed Burner and it says that it can’t find a feed even though when I type in my blog address it picks up that the feeds are there. I then ran it through the feed validator (feedvalidator.org) and it spat this error out:

    line 78, column 0: XML parsing error: <unknown>:78:0: junk after document element
    <script language=javascript>

    I would fix this but it’s all PHP so I have no idea how. My blog address: http://bhamono.com/1330

    Please help!
    Ben

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Start with the usual trouble shooting steps. Deactivate all of your plugins and switch your theme to Twenty Eleven.

    Once that’s done re-validate your theme and confirm that the problem went away. If it did go away, then re-acitvate the plugins one at a time until the problem comes back. Put your theme back last.

    That will help you identify where the problem is.

    Hey I still get the error after switch theme to Twenty Eleven and deactivate all plugins. IE spits this error out:

    Only one top level element is allowed in an XML document.
     Line: 125 Character: 2
    
    <script language=javascript>

    Feedburner gives the same error as before.

    I addition to all this I have redownloaded the latest wordpress from wordpress.org and replaced all the RSS files in wp-includes.

    What else can I do?

    AAARRRGGGGGGG!! I just discovered what the problem was. I added some scripts to index.php in the root of wordpress that redirected iPhone users to my web app, but once I deleted that, IT WORKED!!. OMG LOL. I DUH SO FAIL.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] RSS not working. XML parsing error.’ is closed to new replies.
Skip to toolbar