WordPress.org

Forums

RSS Not Working (10 posts)

  1. CSS
    Member
    Posted 8 years ago #

    I installed WP through Cpanel Fantastico made a simple post. Added some plugins etc.
    When I checked the RSS feed it said page could not be displayed.

    Since I made some modifications my thoughts were that I messed something up.

    I unistalled and reinstalled. Checked the RSS feed with out making a post and got the same error.

    Any suggestions?

  2. Chris_K
    Member
    Posted 8 years ago #

    A link would've been VERY useful.

    So I'll guess.

    I'll guess that your theme has "feed:" as the protocol when you click the RSS link. And I'll guess that your browser is throwing an error because it doesn't know what to do with the "feed:" protocol.

    So, continuing down that road, I'd suggest modifying the theme you're using to remove the "feed:" part of the link.

  3. CSS
    Member
    Posted 8 years ago #

    I just now tried to click on the "rss feed for this thread" and got the same error.

    I manually deleted the feed part feed:hhttp;sflalfa from the address bar and it came up corectly.

    Where do I change that setting in my theme. I just used the default theme.

    http://www.family-watch-dog.info

  4. Chris_K
    Member
    Posted 8 years ago #

    did you notice that the URL for "RSS feed for this thread" starts with the "feed:" protocol?

    Most browser don't know what that is and will throw an error.

  5. CSS
    Member
    Posted 8 years ago #

    Where do I change it in the wp setting

  6. Chris_K
    Member
    Posted 8 years ago #

    In your theme.

    still guessing since you haven't shared a link to your site, but typically the RSS feed links are in the sidebar or footer.

  7. CSS
    Member
    Posted 8 years ago #

    Sorry I edited my post above with the url

    here is is
    http://www.family-watch-dog.info

  8. Chris_K
    Member
    Posted 8 years ago #

    In that theme's footer.php (/wp-content/themes/default/footer.php) find this line towards the top:
    <br /><a href="feed:<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    Change it to:

    <br /><a href="<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

  9. CSS
    Member
    Posted 8 years ago #

    Thanks
    That was it.
    This is my first attempt with WP
    It's nice to know there is a super quick avenue for support.

    Thanks for your help

  10. Chris_K
    Member
    Posted 8 years ago #

    :-) Glad you got it -- and happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.