Support » Fixing WordPress » RSS Not Showing Full Text

  • I just upgraded my WordPress – mainly so that when I used full text in my RSS feeds, the more link would convert to, well, a more link. In my old version I had to manually put the more links in the excerpt.

    So I upgraded and everything seemed fine, but now my default wordpress feed = http://www.animejb.net/feed/ and frankly all my other feeds, ONLY display excerpts.

    My Options->Reading->Full Text for the Syndication feeds is on. I did have podpress installed but I’ve even deleted the folder from plugins and it still doesn’t work.

    This is very perplexing, any suggestions?

Viewing 15 replies - 16 through 30 (of 34 total)
  • I’m in 2.1 – any idea what php file to edit in our case?

    There should be no need to edit the files. Just use a plugin like the original Full Text Feed plugin which strips the more tag, or my DualFeeds plugin, which does the same, except it also creates a summary feed as well as the full text one.

    I’m having the same problem. There’s no MORE tags in my feed (I’ve verified this). I’ve also tried the plugins you mention above. Nothing works.

    I’m having the same problems (v2.3.2). I’ve chosen “Full text” and I’m not using “more” tags, but the RSS feed still is truncating.

    I tried DualFeeds, but that still had the same symptoms.

    I finally fixed it by editing my wp-includes/feed-rss2.php as described above by Mojofofofo

    Any plans to fix this officially? Otherwise I assume I may have to keep “re-fixing” this with every release.

    I’m having this problem on one of my websites too.

    Its interesting, that on one site its ok, and on my second website the feeds are striped to 50 words with no html in it even with the full text option activated in wordpress.

    I have tried all the suggested above to fix this, but I didn’t have any success

    Any ideas?

    I’m sad that nobody claiming to have this issue remembers to share a link to their feed and mention HOW they’re determining it is a short feed.

    If you’re looking at it in Firefox, for instance, you’ll only see it truncated — but it isn’t. View Source and you’ll see the real feed you’re sending.

    ok sorry for that…

    http://open-mania.com/rss

    It redirects to feedburner, and no I’m not using Firefox to read Feeds, I’m using newsfox and google reader, and they all display full feeds from other major blogs, like lifehacker and and downloadsquad.

    Has does anyone have a solution for this??

    This is a real bug, quite blatant. First noticed the problem when full posts weren’t coming through to Facebook note importing, and also verified it by viewing source in Firefox, the RSS actually does have truncated excerpts only regardless of the setting in the options.

    This has nothing to do with the <!–more–> tag, absolutely nothing. The code in feed-rss2.php shows the bug pretty clearly, seems the excerpt is the only text being included regardless of the option setting.

    Mojofofofo’s fix works great, but it’s a hack. Can we fix this in the main WP trunk please? It’s been a long long time. Is there a bug open?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    This has nothing to do with the <!–more–> tag, absolutely nothing. The code in feed-rss2.php shows the bug pretty clearly, seems the excerpt is the only text being included regardless of the option setting.

    No, it’s not, it’s just that people are not actually looking at the feed and only seeing it in Firefox or whatever.

    WordPress’s full text feed WORKS.

    Look closer at feed-rss2.php. Here’s the relevant code:

    <?php if (get_option('rss_use_excerpt')) : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    	<?php if ( strlen( $post->post_content ) > 0 ) : ?>
    		<content:encoded><![CDATA[<?php the_content() ?>]]></content:encoded>
    	<?php else : ?>
    		<content:encoded><![CDATA[<?php the_excerpt_rss() ?>]]></content:encoded>
    	<?php endif; ?>
    <?php endif; ?>

    That’s a complex piece of code, so let’s make it simpler, so that everybody can understand it.

    if (we're using summary feeds) {
       Show <description>EXCERPT HERE</description>
    } else {
       Show <description>EXCERPT HERE</description>
       if (the post content is not empty) {
         Show <content:encoded>CONTENT HERE</content:encoded>
       } else {
         <content:encoded>EXCERPT HERE</content:encoded>
       }
    }

    See? The idea is that the description tag always contains the excerpt, while the content:encoded tab has the full text in it. Firefox always shows the description. Every real feed reader on the planet uses the content:encoded if/when it is available.

    WordPress does NOT have a bug here. You don’t need to do any workarounds. Really. Just enable the Full Text mode in the settings. The setting works correctly and exactly as it is supposed to work.

    This is happening to me too on 2.3.2. It’s certainly got nothing to do with firefox as it’s same in IE and Outlook.

    http://www.wapshere.com/missmiis/?feed=rss

    Like the others here I have selected “full text” under options -> reading, and I’m not using <!–more–>.

    I made the change descibed above to the rss2 file and now that feed is working correctly.

    http://www.wapshere.com/missmiis/?feed=rss2

    I would definitely call that a bug!

    Carol

    PS Looks like there is some sort of firefox issue, but I was also testing this in IE and Outlook, and changing that line has fixed the problem.

    For folks using feedburner, and the feedburner feedsmith plugin:

    I was struggling with this issue for a while, but was able to fix the problem without doing any php revisions.

    The problem was that in feedburner, I had set my wordpress feed location to http://www.naturalcondition.com/?feed=rss2. For some reason, feedburner doesn’t handle that location correctly, and only grabs the description. I changed the feedburner location of my feed to http://www.naturalcondition.com/feed/ (and http://www.naturalcondition.com/comments/feed/ for comments) and feedburner began grabbing the full-text feed.

    I realize not everyone here uses feedburner, but this might help some people.

    mnol

    I don’t know what to say… but.. a.. a..

    YOUR A GENIUS!!

    Finally I have full feed on my blog

    Everyone who doesn’t have full feeds even tho you have that option checked, try this and it will solve your problem 😀

    Thank you, for sharing this

    This is definitely a bug. Just looking at the code shows that it was mis typed. Follow the logic of the code:

    if (get_option(‘rss_use_excerpt’))
    // output the_excerpt_rss
    else
    // output the_excerpt_rss

    So the code, as provided, outputs the EXCERPT no matter what your settings are.

    Very big problem to users, very small effort to change. I’m just wondering why it isn’t fixed?

    Is there somewhere to report bugs?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    patternsofchaos: Yes, you can report bugs on trac, however, that is not a bug. You’re reading it wrong. Really, I made the same mistake myself once.

    Look closer at where the { and } signs are.

    The full text option controls whether or not the content:encoded section is output. The description section always contains the excerpt, as it is supposed to.

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘RSS Not Showing Full Text’ is closed to new replies.