Support » How-To and Troubleshooting » RSS Not Showing Full Text

RSS Not Showing Full Text

  • I just upgraded my WordPress – mainly so that when I used full text in my RSS feeds, the more link would convert to, well, a more link. In my old version I had to manually put the more links in the excerpt.

    So I upgraded and everything seemed fine, but now my default wordpress feed = http://www.animejb.net/feed/ and frankly all my other feeds, ONLY display excerpts.

    My Options->Reading->Full Text for the Syndication feeds is on. I did have podpress installed but I’ve even deleted the folder from plugins and it still doesn’t work.

    This is very perplexing, any suggestions?

Viewing 15 replies - 1 through 15 (of 34 total)
  • Well… head back to Options -> Reading. See right below where you chose between Full Text or Summary? It says,

    Note: If you use the <!–more–> feature, it will cut off posts in RSS feeds.

    At first glance, it seems you are using the <!--more--> feature. So, if you don’t want posts cut off, you may want to look at a plugin like this one.

    But that’s just it, I want it to cut off posts at the more, but it’s cutting them off WAY before. Check out my first two entries – that isn’t where i put the more (I put it after the episode summaries).

    What are you using to view the feeds?

    I see the first article, in the feed, show the “more” right at:

    Deianeira refers to it as the last Nodos, and says that inside it is the one kept by the Hero Tribe that they were searching for.

    Looking at the blog, that seems to match, yes?

    Wait, now it’s working right, but not in my Firefox. I even cleared the cache! How rude!

    I’m having the same problem. Only, my issue is that I have the “full text” option turned on AND I’m NOT using the <!–MORE–> feature. I’m still only getting partial text in my RSS feed.


    I have the same problem : wordpress 2.1, the “full text” option turned on, I am not using the <!–MORE–> feature neither and I am still getting partial text in my articles feed.

    Anybody can help ?

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    What are you using to determine that you’re not getting the more text? Are you actually looking at the feed, or are you looking at the feed in Firefox or in some reader or something?

    Posting a link to the feed would be helpful as well.

    Also, if you’re using feedburner, then I would suggest looking at your original feed or temporarily disabling the feedburner plugin for us, so that *we* can look at your original feed.

    I have disabled the feedburner redirection. My feed adress is http://blog.barbayellow.com/feed/atom/

    Thanks for your help

    I get the same problem, Full text is selected and i don’t use more, i’m looking at the feed in firefox (view source) also I’m getting a mess of unformatted text, all the html is stripped.

    I have this on 2 sites, it worked fine before i updated

    I’m having the same issue.

    i’m having the same issue right now.

    updated to 2.2 same story 🙁

    Me too on 2.1. Upgrading one of my blogs to 2.2 in the hope this will resolve the issue.

    Its a problem on all my sites including my number 1 (see below)


    I have disabled the re-direct for now.

    I have just decided to use the full-feed plugin that apparently addresses this issue.

    I looked to see if 2.2 addresses the issue but looking at ‘Trac’ I couldn’t out if it does and apparently Paul is also struggling and he uses 2.2.

    I find it a bit shocking that so many have this problem yet somehow it wasn’t addressed in 2.2. If this many people are having a problem its not random.

    Anyway if you want to see my site and see that it works now click the link above I won’t be cheeky and add my website again as I know the Google Juice is good on this domain and I respect that.


    I am using v2.2. I had to modify wp-includes/feed-rss2.php line 37. I changed the_excerpt_rss() to the_content_rss() and the feeds came out full-text after that.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘RSS Not Showing Full Text’ is closed to new replies.