Support » Fixing WordPress » RSS Not Showing All Posts

  • Okay, I’ve been round and round on this one, and I’ve searched these forums through and through. Here’s my setup..

    – I’m using the MiniPosts plug-in, so I can make little entries (I call “little spiffies) of basically just links. They show up on the front page, in a little sub-column.

    – I show just ONE post, from the “featured” category at the top of my index page

    – Below that, I’m showing the most recent 8 posts, making sure to not include any of the “little spiffies” posts, but the most recent 8 posts from all other categories combined.

    – I’m using

    Okay, so my RSS feed ( ) shows only ONE post, and it’s always only from my “little spiffies” category, even though I’ve set the MiniPosts plugin to separate its content from my RSS feed.

    I’ve tried using feedburner, and the feedburner plugin (which is great, btw), but no amount of trying to get this damned RSS feed to show up, no matter which method or protocal I use, has any effect that differs from the aformentioned problem.

    Here are the following things I’ve tried :

    – Upgrading to

    – Disabling the Feedburner plug-in, and using the default WP RSS link

    – Manually linking to the new feedburner link without the FeedBurner plugin

    – Using the default theme, so it shows all posts regardless of category on the front page

    – Disabling the MiniPosts plugin

    – Setting the MiniPosts plugin to not separate its content from my default RSS feed

    – Loading up each of the feed URLs WP provides (rss.php, rss2.php, etc) in both Safari and Firefox, using both “feed: //” and “http: //”

    My site is at :

    Any help would be immensely appreciated at this point. I just moved to WP after having used MT for all of my sites for the past 2 years, and I really dig on it. I’m just racking my brain over this RSS issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • maybe a question too simple, but in wp-admin, under options>>reading>>RSSfeeds, how many did you put on “show most recent” ?

    Oh yeah, forgot to mention – I have it set to show the 15 most recent posts, as full text. I’ve also tried it as summary but.. no good. I have the “blog pages” set to show the most recent 10 posts (I’m guessing this only affects category archives on my site, however).

    BTW, My comments RSS feed works just fine.

    I don’t mean to rehash old posts, but I still can’t figure this thing out. I have the following plugins enabled (I’ve disabled each one, and used all the default theme files just to try and it STILL didn’t work)

    – Get Recent Comments
    – Gravatar
    – Limit Posts
    – MiniPosts
    – More Div
    – Polls
    – Popularity Contest
    – Simple Search and Replace
    – Smart Archives
    – Tiger Style Administration
    – WP-Contact Form
    – WP-Scrobbler
    – WP-Paginate

    I was also using the Feedburner Feed Replacement, and though it said it altered my .htaccess file, it didn’t appear to actually forward my feed links to my feedburner URL. So, I’m not sure that worked. Right now, I’ve got that disabled and I’m linking to the default feed file, located at :

    I was thinking it might have something to do w//the .htaccess file – but if I delete what’s in there right now, will WP replace it w/all the necessary things again if I update my permalinks? I don’t want to lose traffic or functionality through doing that. Also, any good links to a manual tutorial on using Feedburner with WP? I found one about a week ago but I’ve not been able to track it down again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘RSS Not Showing All Posts’ is closed to new replies.