Support » Installing WordPress » RSS Not found/Not registered protocol

  • Resolved surferbill

    (@surferbill)


    I’m in the process of setting up my blog and the layout and whatnot. I clicked on both RSS links in my footer and neither of them work.

    my URL is http://www.grooveconcepts.com/

    In FireFox i get a pop up error window that says “Alert Feed is not a Registered protocol”

    In IE it takes me to a page cannot be displayed error page. In the title bar it says Invalid Syntax Error

    As far as I know, I really haven’t touched footer.php where these links reside. Also, I have the most recent version of wordpress installed.

    Any help would be very much appreciated, thanks in advance!

Viewing 15 replies - 1 through 15 (of 27 total)
  • I looked in the footer.php and it was making the URL to be

    feed:http://www.grooveconcepts.com/feed

    I’m not sure if feed: is supposed to be at the front like that. any ideas?

    I removed the feed: part and I think its working now…I just hope I didn’t take out something I need

    Moderator James Huff

    (@macmanx)

    Your feed is fine at: http://www.grooveconcepts.com/feed/ The problem is the feed: in front of it. You can see an explanation here: http://wordpress.org/support/topic/29291#post-164887

    And, please upgrade to Firefox v1.0.4 as soon as you can. Currently, it’s the only version of Firefox (and the only cross-platform browser) that can correctly handle feed:.

    Awesome thanks a ton for looking into that for me, I really appreciate your help!

    Moderator James Huff

    (@macmanx)

    No problem. ^_^

    And, please upgrade to Firefox v1.0.4 as soon as you can. Currently, it’s the only version of Firefox (and the only cross-platform browser) that can correctly handle feed:

    Odd, running 1.0.4 and it has no clue what to do with feed:.

    feed is not a registered protocol.

    It’s not the browser that supports the “protocol.” The “feed:” protocol scheme is similar to “mailto:” in that a program needs to be installed and registered in the OS as the supporting application. When I click on a mailto link my email application loads, and when I click on a feed link my RSS reader opens. But if I don’t have programs registered as the default apps, they don’t work.

    Yes, but it’d be nice if Firefox had the ability to hande the “feed:” protocol since it can handle feeds as bookmarks.

    I’m running Firefox v1.0.6 and I’m getting the same error message. What is a recommended RSS reder so I can default the protocol to that app?

    What is a recommended RSS reder

    For Windows, I can recommend SharpReader:

    http://sharpreader.com/

    Thanks so much I’ll check it out on my windows machine. But I also have a linux desktop that I use quite a bit. Any suggestions here?

    I think I am having a similar problem. I apologize for being completely clueless but this is my first blog. When I am in i.e. and I click on the entries (RSS) link at the bottom of my blog I get “This page cannot be found” The address of the blog is
    http://www.blindpigfindsacorn.com/blog

    Whatever the problem is, would you mind being excruciatingly clear in your directions of what to do about it… I apologize again for not knowing what I am doing. Thanks!

    skippy

    (@skippy)

    Member

    porca:
    the RSS link at the bottom of your page is this:
    feed:http://blindpigfindsacorn.com/blog/?feed=rss2

    The feed: bit at the front is causing problems. feed: is a nascent standard, not yet widely supported by many applications. WordPress uses this format to help (try to) jump-start the market for its use. It’s a bit of a chicken-and-egg problem.

    To remove the feed: prefix, simply edit the footer.php file in your wp-content/themes/default/ directory.

    Thank you skippy, I would like to say this worked but instead it is broken worse – no doubt my fault. I opened the footer.php file in notepad and there were two lines with feed: in them.

    The first line had “>Entries

    After removing the feed: it now says

    Entries

    I saved it as footer.php and reuploaded and now when one clicks the entries (RSS) link one gets an exciting page of code. What did I do wrong?

    well heck, that post is not correct now because this system executed some of the code. Dunno what to do to stop that from happening so I can show you the code I changed and how I changed it 🙁

    never mind, I retract the question, I’m an idiot – it is now working correctly thank you Skippy!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘RSS Not found/Not registered protocol’ is closed to new replies.