Support » Plugin: Jetpack by WordPress.com » RSS No Longer works

  • Resolved pasqualerose

    (@pasqualerose)


    I started using the Jetpack features on Friday. Ever since then my automative email service no longer works. It seems Jetpack shut down my RSS Feed. What would cause this?

    Thanks!

    Pat

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Your RSS feed works: https://visualverse.thecreationspeaks.com/feed/

    But, it’s no longer valid: https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fvisualverse.thecreationspeaks.com%2Ffeed%2F

    Try deactivating all plugins, then check the validation link again.

    If it’s finally valid, reactivate each plugin individually (re-checking each time) until you find the plugin causing the problem.

    If it was still not valid with all plugins deactivated, switch your site to the Twenty Nineteen theme and check the validation again.

    As for email subscriptions, it appears that you have not enabled that feature in Jetpack yet: https://jetpack.com/support/subscriptions/

    Sorry. I did not receive a notification of your reply. Not even in my spam. I usually receive notifications of replies to my post. I’ll have to recheck my settings

    Thanks for your reply.

    The RSS problem started on Friday, March 15th. That is the day I started using many of the JetPack features.

    The feed starting working on Monday when I turned off several JetPack features including the accelerator. I’m not sure why this link (https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fvisualverse.thecreationspeaks.com%2Ffeed%2F) says it’s not working.

    As far as email subscription for my site, I use MailChimp and have a sign up link on my pages and posts. MailChimp reads my RSS feed and sends out emails when I make a new post. I discovered the RSS was not working because MailChimp stop sending emails. When I turned off various JetPack features MailChimp started working again on Tuesday.

    So I don’t think I need turn off any plugins. It seems like the cause was with JetPack.

    Any other ideas?

    Thanks!

    Pat

    • This reply was modified 1 month, 4 weeks ago by  pasqualerose.
    • This reply was modified 1 month, 4 weeks ago by  pasqualerose.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    This would be the first report we have of Jetpack breaking an RSS feed, so I’m not sure starting there is the right point.

    It is possible that Jetpack did something to make the already invalid RSS feed worse though, that tends to be the way invalid things go.

    Would you please try the steps mentioned earlier to get that RSS feed valid first, then we’ll move from there?

    I’m always cautious about turning off all my plugins. I don’t want to mess anything up. That seems like it can create more problems. Will I have to reset all the settings for my plugins?

    Thanks,

    Pat

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @pasqualerose,

    Will I have to reset all the settings for my plugins?

    Settings should remain in place when a plugin is deactivated (deleting them would remove the settings though). If you’ve spent quite a bit of time setting things up, taking a site backup before doing anything might put your mind at rest.

    Ok. Thank you.

    And I will do a backup as well.

    Plugin Support Gemma Evans

    (@gemmaevans)

    Great, let us know how you get on 🙂

    So I turned off all my plug-ins and turn them back on one at of time. When I turned on a plug-in that allows for the featured image to be picked up in an RSS feed validator.w3.org/feed/ showed that the RSS feed no longer work. But yet MailChimp still is able to read the RSS feed from my site. So it must be still working.

    Each time I make a new post MailChimp creates an email and sends it to my subscribers with the featured image included. The only time this did not happen is when I turned on the accelerator in JetPack.

    Both https://castfeedvalidator.com and https://podba.se/validate/# say I have a RSS feed. So I am getting conflicting information. I’m open to ideas as to why this would be.

    Thanks,

    Pat

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @pasqualerose,

    When I turned on a plug-in that allows for the featured image to be picked up in an RSS feed validator…

    What is the name of that plugin? From what you’ve said, this sounds like a possible conflict with that plugin and also Site Accelerator.

    Once we know exactly which plugin you are using, we can check to see if there are any known issues.

    Hi Gemma. Sorry for my delay. I am not getting notified of replies. I have the box checked to get an email, but they don’t always come. When they do come they often go in my spam, but I check that too. I didn’t receive an email that you replied.

    The plugin is “MB ImageChimp RSS Feed Enhancer”

    Thanks!

    Pat

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Thanks for letting us know! 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.