Support » Plugin: RSS Importer » RSS Importer plugin compatibility issue with PH 7

  • I ran the PHP Compatibility Checker for PHP 7 and found this plugin had an error and warning. Can you please help me address and resolve the issue or recommend another to replace it if this plugin will no longer be supported? The following is the error and warning details on the report:

    FILE: /home2/pruppel/public_html/wp-content/plugins/rss-importer/rss-importer.php
    ———————————————————————————————————–
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    ———————————————————————————————————–
    71 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    212 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————————–

    Thank You

    Pat
    [Signature links removed by moderator per forum guidelines.]

    • This topic was modified 2 years, 6 months ago by James Huff.
Viewing 1 replies (of 1 total)
  • Thread Starter PatRuppel

    (@patruppel)

    Haven’t heard back yet. Is there a compatibility issue (got an error and a warning) with this plugin for PHP 7. I haven’t checked compatibility with higher PHP’s like PHP 7.2 and it’s being recommended to update our WordPress sites. Mine is self-hosted. I wanted to get feedback before I continue on with the PHP update.

    Thank you

    Pat
    [Signature links removed by moderator per forum guidelines.]

    • This reply was modified 2 years, 6 months ago by James Huff.
Viewing 1 replies (of 1 total)
  • The topic ‘RSS Importer plugin compatibility issue with PH 7’ is closed to new replies.