Support » How-To and Troubleshooting » [Resolved] RSS feeds stopped working after upgrade to 2.7

[Resolved] RSS feeds stopped working after upgrade to 2.7

  • Today I upgraded to WP 2.7. Everything went fine, except the RSS feeds are now gone. Every request to site.com/feed/ or site.com/?feed=rss2 ends up in a 404 Not found. Did anyone encounter this error? How can I debug this? I tried to deactivate all plugins with no effect.
    Thanks for your ideas.

Viewing 15 replies - 1 through 15 (of 15 total)
  • did you verify that the files were uploaded properly? when you view through FTP can you see that the file is there? There are noted problems with Filezilla and uploading files properly (most often with javascript libraries) and though some found that it has been fixed in the new version that has not been my experience.

    Yes, I uploaded the files one more time, just to check everything’s alright. I also quickly viewed most of the files that has something like “rss” or “feed” in their filenames and they looked alright.
    Is there a way to debug this? All I can see in Apache error logs are plain 404.

    I am having the same problem!

    Can anyone help? The actual URL is http://gambo.cz
    Neither http://gambo.cz/feed or http://gambo.cz/?feed=rss2 works 🙁

    I too am having this same problem.

    I’m having the same issue, my rss stops working..

    I had a similar problem where the rss feed no longer responds to any updates. I noticed that when I click on the link, my wordpress directory that I called blog would change to wordpress. For example,
    http://www.mysite.com/blog/?feed=rss2 would change to http://www.mysite.com/wordpress/?feed=rss2 and would not find the page. When I changed the script to use rss instead of rss2 at the end it started to work again. Hope this helps.

    Hi all
    I’ve just installed wordpress and as far as I can see RSS feeds do not work in 2.7 or 2.7.1-beta

    if you search these forums you will find lots of requests for help and no one giving any answers


    if you search these forums you will find lots of requests for help and no one giving any answers

    that’s crap and you know it – you just linked to a thread with 23 replies

    rss feeds work fine in 2.7 99.9% of the time – the other .1% could be user error, server error or any number of problems

    don’t start acting like some victim now

    My RSS feed does not show for my blog which is in a subdirectory.


    The RSS feed works fine for my other sites without the sub directory.

    Is there someway to over write this?

    Someone on another thread had success re-writing something in the includes folder, but the instructions were truncated in the link they included.

    Thank you for your help!!!!!!! It’s been ages since I have reported this issue.

    I was able to resolve this error with help from my host Bluehost (I think their customer service is great!):

    Disable all of your plugins and reactivate them one by one. That way you will see which plugin is causing the problem.


    ageorgegal: Lucky you! I tried this long time ago, but to no avail.

    I was hoping maybe 2.7.1 will fix this problem but I had no luck again 🙁
    I’m sad that nobody suggested any hint, how to DEBUG this problem. I would like to chase this problem/bug but I’m unable to find any info about what’s happening inside Wordpres…

    Ok, so solved. For some reason, Apache rewrite wasn’t working well. So “/feed” URI ended in 404, because it doesn’t exist in reality (it’s handled by WordPress internally).

    @ marekles: I think I have the same problem here as you have.
    Could you provide me with a solution?
    Thank you for any help in advance.

    My website >> http://www.bwave.de

    Ditto – I ma having that problem – can someone suggest a fix?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] RSS feeds stopped working after upgrade to 2.7’ is closed to new replies.