RSS Feeds not working in IE7 (12 posts)

  1. takuhii
    Posted 8 years ago #

    I am having some problems getting the RSS feeds to work on my blog in IE7. If you look at my site: http://takuhii.x10hosting.com/ and click on either of the RSS feeds options on the right hand side in IE7, you'll see what I mean...

    Any info would be greatly appreciated, any recommendations of plugins to help rectify this problem would also be greatly appreciated.

  2. drmike
    Posted 8 years ago #

    Well, one, never assume that "you'll see what I mean..." will be what other people see.

    Especially considering I see a feed fine from that link. :)

  3. takuhii
    Posted 8 years ago #

    Ah BUM! I knew this would happen... Everyone can see it but me (works fine in Firefox doesn't it). Basically if I click my RSS link in IE7 I get a "Page cannot be displayed" page, with the URL: feed:http://takuhii.x10hosting.com/feed/ in the address bar.

  4. Edit your template/theme to remove the leading "feed:" text from those links.

  5. RodSchell
    Posted 8 years ago #

    I have the same issue except all is good with Firefox. Is there a trick to make IE work with the rss feed? http://www.allcan.org/blog

  6. Same problem, same solution. Remove the word "feed:" from your theme.

  7. RodSchell
    Posted 8 years ago #

    Are you referring to the link or is there a file for the theme that I need to vi?

  8. Look in your theme's files. Search for "feed:". It will be part of the link to your RSS feed.

    Remove the prefix of "feed:". IE does not understand that prefix. It's really just that simple.

  9. RodSchell
    Posted 8 years ago #

    Worked perfectly, thank you for the help. Gotta like the quick fixes:)

  10. converting2wp
    Posted 8 years ago #

    Here's a different interpretation of "rss feed not working" and a solution, however obvious, that may help some who stumble on this thread.

    IE 7 has an option to turn on feed reading. I swear I don't remember turning it off, but when it's off the feed just appears as a "raw" XML file. So, to turn it back on...

    1) Click on the Tools menu,
    2) Click on the Internet Options sub-menu,
    3) Click on the Content tab,
    4) Click on the Settings button of Feed section to bring up Feed Settings dialog box,
    5) Tick the check-box of Turn On Feed Reading View option.
    6) Click OK all the way to close all opened dialog boxes.

    Thanks to this post for the steps.

  11. hoppingghost
    Posted 8 years ago #

    Ah, removing "feed" worked like a charm. My site--well, the site I've been interning for, heh--was having problems with this and they asked me to fix it as my last task for them but I didn't know how...it's all good now. Thanks!

  12. gversion
    Posted 8 years ago #


    I am having the same problem - the RSS feeds aren't working in IE7. I have searched for 'feed:' in the theme code but can not find it.

    All I can find is the following in sidebar.php:

  13. <h2><?php _e('RSS Feeds'); ?></h2>
  14. Can someone please help me out with this?

    Many thanks,

Topic Closed

This topic has been closed to new replies.

About this Topic