Support » Fixing WordPress » RSS Feeds Not Working

  • As of one week ago, my feeds stopped working, and I get Error: 404 not found errors on every possible feed address. Feedburner redirect plugin is turned off while I try to figure this out. I tried disabling all the plugins and re-testing the feed but that was not the problem.

    The site: http://www.trueup.net

    Host confirms that the .htaccess file looks fine.

    I did upgrade to 3.1.2 recently, and recently added some custom post types and taxonomies and had some trouble with the permalinks for the taxonomy listing pages (all I had to do was visit the permalinks setting page and they were flushed & fixed).

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m getting 404s on all of your page links (for example trueup.net/about/) so I would first try saving your premalinks again.

    Done, but the 404s are still happening.

    OK, simply changing the permalink path fixed everything. Now the problem is that the feeds are showing truncated posts, but I have them set to full text.

    Which feed URL did you enter on Feedburner?

    It’s hard to say, but I would guess that a plugin is resetting your default feed type.

    Do you know which plugins are affecting the feed? Do any have a settings pages where you can specify the feed type to use?

    I removed the WP-Socializer Plugin because I didn’t want those links in my feed, went to bed, and sometime overnight the feed began showing up correctly.

    But now the 404 problems are back — better start a new thread on that though.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘RSS Feeds Not Working’ is closed to new replies.