Support » Fixing WordPress » RSS Feeds Don’t Work

  • Resolved mikegreer

    (@mikegreer)


    Help, please! My RSS feeds aren’t working right.

    Background on my skill level:
    I have a new, as yet unpublicised blog created with WordPress. (Wow! Thanks to all you who maintain and create this wonderful software!) I am not a programmer of html or anything else. However, I have used MS Frontpage for many years to create and maintain my non-blog, non-WordPress website and have, once in a while, poked in the html view in Frontpage to put in Google AdSense ads or make other monkey-with-a-Swiss-Army-knife type tweaks.

    The current situation:
    To create pages in my new blog (new webhost, new URL), I used WordPress Dashboard as an ordinary user [non-programmer], working with “Visual” tab, not the “Code” tab. I then uploaded and installed from the WordPress approved theme library “Positive Feeling 1.2 by Roy Tanck.” Beautiful theme! (Thanks, Roy!)

    Using Internet Explorer 6.0, when I click on the pre-programmed “RSS” link or the “Comments RSS” link, I get the message “The page cannot be displayed…currently unavailable.” Here are the respective URLs of these links:
    RSS link: feed:http://www.bestfreetraining.net/?feed=rss2
    Comments RSS: feed:http://www.bestfreetraining.net/?feed=comments-rss2

    The WordPress Feed Validation Service, when applied to either of these feeds reports: “Congratulations! This is a valid RSS feed.”

    Using Firefox 2.0.0.9, when I click on these feed links, they allow me to establish a proper feed link — at least to My Yahoo page. However, after I set them up on My Yahoo, the links display, but do not appear to be actively working — they don’t update when I change something at my blog.

    What’s a non-programmer to do?? I’m afraid to publicise the site until this is resolved.
    Thanks.
    Mike Greer

Viewing 15 replies - 1 through 15 (of 24 total)
  • Try feedburner.com. If it tells you that your feed is valid, then I’m guessing it’s just an update delay. I use Google Reader and it can be hours between a post and having it appear in the reader.

    Could you clarify? What do you mean by “try feedburner.com?” (Newbie needs steps, please.)
    Thanks for your reply.

    feed:http://www.bestfreetraining.net/?feed=rss2

    Delete the word feed: from the beginning!

    And it will update only if you add new posts. I added your feed (with the correction above) to MyYahoo and it displays 3 posts… 1 written a day ago and 2 written 2 days ago.

    Thanks, Moshu, for being there! Now then, FYI: I added a test post just a few hours ago. Shouldn’t it have displayed? (I’ll forget about this for now… back to your suggestion.)

    In the meantime, you said: “Delete the word feed: from the beginning!”

    OK. This blind man is finding his way around the elephant! Here’s what I did:
    1. I went to the blog’s home page with IE Explorer.
    2. I clicked on “view source”
    3. I scrolled around and found this: “<h2>Meta</h2>”
    4. I looked beneath that and found what I believe to be the offending entries, each beginning: ”

  • <a href=”feed:http://www.bestfre…”
  • Cool! You directed me to the problem! Now, how can I edit this page? In particular,
    1. What is the name of this page? (so I can find it on my server)
    2. How can I edit/save it? (i.e., using what editing application — is Notepad okay?)
    3. Are these “deeper” type files available to me for editing from WordPad’s Administrator Dashboard? If so, were in the Dashboard should I go to find this capability?

    Moshu, I know I write long-winded stuff. (I am a writer, after all!) And I really appreciate your help. But I think I am really close to resolving this and leaving you alone! So, begging your patience one more time…

a. Re updating.
Is the update services there in your blog?
(Options > Writing… below)

b. Editing.
The best way to do it: edit on your computer and upload the files via FTP to the server. Notepad is very OK 🙂

What is displayed on your blog is always defined by the template files in your theme (active theme).
This particular link in your sidebar should be in… sidebar.php – at least in most normal themes it should be there.

re: a. Re updating.
In Dashboard, in the grey box at the bottom, under “Update Services…WordPress automatically notifies…” is listed: “http://rpc.pingomatic.com/”
That’s all.

re: b. editing
I searched my Host server and found a whole bunch of “sidebar.php” — I suppose this is because I downloaded and installed some 13 or so themes to test. Anyway, all my “sidebar.php” files are either here:
Public_html/wp-content/themes/[theme name]/sidebar.php
or… here:
Public_html/wp-admin/sidebar.php
Which one should be edited?

Again. You do NOT edit anything online – aka on your server.

I assume you have all those themes on your computer… since you said you have downloaded and installed XX themes.

Now forget the server and go and find the theme on your own computer.
The one that is in use now and you want to edit. And edit its own sidebar. Nothing else.

Hmmm… I only have zip files on my computer.

I followed what I believed to be the instructions for adding themes, which told me to download a zip file for each theme to my computer, then upload each of these and unpack them on my server. All editing and setup of the blog has been online, using the installed WordPress (Dashboard) on my server. I have no WordPress-related application on my computer. My computer has only zip files, one for each theme.

Could I use FTP to download a copy of the appropriate file from my server to my computer, then edit it using notepad, then upload it back to the appropriate directory?

Could I use FTP to download a copy of the appropriate file from my server to my computer, then edit it using notepad, then upload it back to the appropriate directory?

BINGO!

THANKS! I’ll try this. (FYI: I was afraid to edit anything in a particular theme’s directory, because I thought that the theme somehow used all its files to generate the site … and there was some sort of “user” directory that my modifications to the theme were kept. Anyway, I’ll let you know how it works.)

Crap! Uploaded the edited file to:
public_html/wp-content/themes/positive-feeling-10
and it still doesn’t work.

One new line now reads:

<li><a href="<?php">" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('RSS'); ?></a></li>
Other new line now reads:

<li><a href="<?php">" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments RSS'); ?></a></li>

You may want to try again posting that code! Put backtick around it `
(they are usually on the left tp, where ~ [tilde] is)

Where should I put the ` mark? In the meantime, I’ve tried all kinds of combinations, with weird results. I need to run some errands, then I’ll try again later this evening. (Sure am glad I haven’t “gone public” with this site yet!)
Thanks.

I have tried all sorts of combinations of deleting stuff, adding stuff, and everything else a non-programmer might try in a monkey-like fashion.

The bottom line: I have restored the original sidebar.php from the theme. The RSS feed buttons work fine with Firefox (and always have) but do NOT work right with Internet Explorer (at least on my machine… IE6). Could anyone else try using IE and let me know? The buttons are in http://www.bestfreetraining.net , right column, front page.

I’m out of ideas. I give up for now.

Paste you sidebar.php to http://wordpress.pastebin.ca
and post back the URL

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘RSS Feeds Don’t Work’ is closed to new replies.