WordPress.org

Support

Support » How-To and Troubleshooting » RSS Feeds are no longer working?

RSS Feeds are no longer working?

Viewing 15 replies - 1 through 15 (of 100 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Hi esmi,
    Thank you for the response, and the suggestions.

    I did what you said, and switched to the Twenty Eleven theme, and, apparently, the problem isn’t with the theme.

    I then tried deactivating all plug-ins, and the problem was still persisting.

    Then, I decided to go to The WordPress Feeds page:
    http://codex.wordpress.org/WordPress_Feeds

    In my Feeds Widget, I was using this code for the posts:
    <?php bloginfo(‘rss2_url’); ?>
    The resulting link would be this:
    http://www.hyperblogcafe.com/feed

    Then, I tried switching to:
    <?php bloginfo(‘rss_url’); ?>
    Resulting link:
    http://www.hyperblogcafe.com/feed/rss

    The result is a lot better. If you click on:
    http://www.hyperblogcafe.com/feed/rss
    You will see that it is better.

    Still, in my Reading Settings, “Syndication feeds show the most recent,” I have it set to display 250, and only the last 10 post feeds are displaying. Interesting, when I view the source on that page, it does show them all. But, in RSS, only the last 10.

    I am having the same thing happen with comment feeds as well.

    So, while this is much better, it is still not optimal.

    Do you have anymore suggestions? Incidentally, I am using Google Chrome. Could that also be contributing to this?

    Thank you,
    Mark

    esmi

    @esmi

    Forum Moderator

    Do NOT pull your own feed url into an RSS widget on your site! This will have a significantly negative effect on your site’s performance.

    Still, in my Reading Settings, “Syndication feeds show the most recent,” I have it set to display 250, and only the last 10 post feeds are displaying.

    esmi,
    I meant to say, when I view the xml file, it appears that they are all there. But, Chrome will only display the last 10.

    But, then, I tried opening IE, and the original problem is still occurring there.

    I will try resetting the plug-ins folder now, and see if that helps.

    Do NOT pull your own feed url into an RSS widget on your site! This will have a significantly negative effect on your site’s performance.

    It’s not a plug-in – It is an advanced text widget, to where I put the custom code. I am not pulling the feed into a widget. They are merely links to the feeds.

    OK, I have also reset the plug-ins folder, according to the instructions on the page you gave me. But, that didn’t do anything noticeable either.

    This is bizarre! Until recently, the RSS feeds worked perfectly.

    Any other suggestion?

    Thank you,
    Mark

    esmi

    @esmi

    Forum Moderator

    Try resetting your custom permalinks back to the default setting.

    Try resetting your custom permalinks back to the default setting.

    Permanently, or just temporarily?

    Temporarily, to test.

    Hi Ipstenu,
    By resetting, I am assuming that you meant to switch the permalink structure back to default?

    If that is correct, I did that, saved it, and my posts weren’t displaying.

    I then changed it back to custom, with the /%postname%/ variable.

    And, the same problem persists. 🙁

    Change the permalinks to default (ugly) – Yes, we know your posts won’t work, that’s expected.

    What you’re supposed to do is test if the ‘ugly’ version of the FEED link works 😉

    http://example.com/?feed=rss
    http://example.com/?feed=rss2
    http://example.com/?feed=rdf
    http://example.com/?feed=atom

    Thanks Ipstenu!

    OK, so, let me get this straight:

    First, switch the permalinks structure to default, then save it.

    Then, try using the 4 Feed (links) methods (above) with my site?

    Yes 🙂

    Ipstenu,

    3 out of the 4 took me back to the original problem that I posted about. And, the ?feed=rdf one was asking to download something. 🙁

    On the defaults widget, by wordpress, they use the /feed method.

    So for me, that would be http://www.hyperblogcafe.com/feed, but, that gives the same problem.

    Any other ideas?

    Thank you,
    Mark

    Ipstenu,
    I tried putting my blogsite (www.hyperblogcafe.com) into this utility: http://feedvalidator.org/

    And, it is saying, “Congratulations! This is a valid Atom 1.0 feed.”

    Also, it is saying:
    line 8, column 23: subtitle should not be blank
    <subtitle type=”text”></subtitle>

    and

    line 33, column 0: content should not contain object tag
    <object classid=”clsid:d27cdb6e-ae6d-11cf-96b8-444553540000″ width=”350″ hei …

    Do you know what this all means, and how it ‘might’ get me straightened out?

    Thank you,
    Mark

Viewing 15 replies - 1 through 15 (of 100 total)
  • The topic ‘RSS Feeds are no longer working?’ is closed to new replies.
Skip to toolbar