Support » Fixing WordPress » RSS feed with MP3 file in blog not recognized by iTunes

Viewing 5 replies - 1 through 5 (of 5 total)
  • Well, as far as I can tell, the reason iTunes can’t read your rss feed is because there are no <enclosure> tags in your feed. Without those, nothing is going to know anything about your podcast – in essence it’s not really a podcast without those tags.

    Now WordPress is supposed to gather the info about your mp3s and put it into your rss feed automagically. I notice when I click on your link I am forwarded to some kind of login page. I can get the mp3, but it’s possible WordPress isn’t able to access it for some reason. For example, I’ve seen server-side php scripts not be able to retrieve rss feeds from some servers because the script doesn’t look like a user agent (a browser or aggregator) to the server that’s providing the file.

    Perhaps you could try linking to an mp3 that’s hosted in a wide-open and accessible location (like in your WP uploads directory) as a test. If that works then I’d say you’d have a pretty good hint that your server is getting in the way somehow.

    Thank you very much Cori – i will try it and see what happpens (so far, my mpegs are too heavy to be uploaded on my WP uploads directory – which is strange in itself… maybe I am in the worong directory…)


    No problem.

    You could try a smaller file in your uploads directory, or even upload it via ftp, just as a test.

    Let us know how it goes….

    Hi Cori,

    I have tried two things to make it work now – still at no prevail:

    1)I now added a second mp3 file link (podcast test2) to an open www address in my posting:

    Testing as podcast through iTunes gives still an error message.

    2) I tried to install PodPress which has been recommended to solve most of the problems related to podcasting in WordPress… but the plugin won’t install in my WordPress 2.0.2 (does not show up in my admin area although installation on wp-content/plugin seems to be correct)
    Please find here my FTP installation screenshot:

    (I even followed video-suported installation on, the developer of PodPress and am posting in their forum as well to understand why it does not work).

    Both attempts to make my podcast work have been without any result so far… should I buy another head?…;-)

    Thank you,

    Hi Stephan;

    You’re right, the install looks correct. The only thing I can think to try is to delete and reupload the plugin – sometimes if a file doesn’t make it to the server properly it can cause problems. I’ll try to install it on my own server tonight.

    I can’t see the 2nd post you posted, so I can’t take a look at that, though.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘RSS feed with MP3 file in blog not recognized by iTunes’ is closed to new replies.