Support » Fixing WordPress » RSS Feed will not validate – Podcast not uploading to iTunes

  • I’m hoping someone can help me. This week I received an email from my host service saying that my server was being repaired and that my website would be down periodically. The website is for my podcast which airs through iTunes every Tuesday. I noticed that the show wasn’t being posted to iTunes, and when I tried to validate the RSS feed I would receive an error message. I contacted my host company (dreamhost) and they looked at my RSS feed and said that it appeared the problem was with feedburner. Well, I didn’t get my RSS feed through them, i just used a plugin to get statistical information. Figuring the show being posted to iTunes was more important than statistics, I decided to deactivate the plugin, figuring that would work. Now the show is visible in iTunes- meaning the liner notes and title- but the audio is not uploaded. There is an error 400 code in iTunes. Now when I try to validate the feed, I get an error message that states : Server returned HTTP Error 404: Not Found. When I type in my RSS feed url into the browser i get another error message that states : Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

    I do not know what to do to fix this. Is this something to do with the servers? It was working fine before the service mess happened. Any help would be greatly appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Jon, I’m sorry you’re having all this trouble after we repaired your server.

    I went and took a look, and your site is running rather slowly, and has this error at the top:

    Warning: Missing argument 2 for WP_Widget::__construct(), called in /home/jonhart/ on line 324 and defined in /home/jonhart/ on line 93

    This is causing the slowness, as it’s breaking WP Super Cache. Given that your theme is TwentyEleven, I would suspect one of your plugins is causing this. You’ll need to turn them off and then back on, one at a time, to see who the annoying one is. Of course, since all this worked before, it’s very likely just turning them all off and then back on will magically work. It’s like a reboot.

    BTW, when I looked at your .htaccess, you don’t have the pretty permalink rules, so if you’re trying to go to the URL, it won’t work.

    I do see the Podcast URL on your sidebar uses this:

    That should be this (unless the podcasting plugin makes an alias for you)


    Thank you so much for the help. I deactivated the plugins like you suggested and found which one was causing the error. The site is still running at a snail’s pace. I will try to change the RSS feed in the podpress settings to see if that will work. Thank you so much for all of your help.

    How do I get the pretty permalink rules? Sorry, I am technologically challenged.

    I’d guess the speed is directly related to the lack of caching, though it looks like caching is sort of working.

    You have the .htaccess working now 🙂 (If you open your .htaccess file you can see it), so the only thing I would do now would be to turn off WP SuperCache and then turning back on again. That should give you any errors with regards to setup.

    By the way, if you’re using Jetpack for stats, you don’t need WP Stats. They’re the same thing, only Jetpack gets updates and WP Stats doesn’t.

    Well I finally get the feed working and now all the content is missing from the site. I have no idea why…Thoughts? Thanks again for all your help.

    well it looks fine now. I guess they are doing something with the server.

    It was probably a server cache gone wild. Not as much fun as it sounds. If it happens again, open a support ticket, and we;ll take a deep look into it for you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘RSS Feed will not validate – Podcast not uploading to iTunes’ is closed to new replies.