WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] RSS Feed validation failure version 2.0.4 and 2.0.5

[Resolved] RSS Feed validation failure version 2.0.4 and 2.0.5

  • johncblacker
    Member

    @johncblacker

    I have recently installed 2.0.4 on my local machine and GoDaddy installed it on their servers for me (2.0.5). All works well except RSS. When I tried to access the feed with I/E, I get a message indicating there is an error…Here is text of I/E reported error:
    Invalid xml declaration.
    Line: 2 Character: 3

    <?xml version=”1.0″ encoding=”UTF-8″?><!– generator=”wordpress/2.0.5″ –>
    When I try using Feed Validator, I get the following:
    This feed does not validate.

    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    <?xml version=”1.0″ encoding=”UTF-8″?><!– generator=”wordpress/2.0.5″ –>In addition, this feed has issues that may cause problems for some users. We recommend fixing these issues.

    Feeds should not be served with the “text/html” media type [help]

    Your feed appears to be encoded as “utf-8”, but your server is reporting “US-ASCII” [help]

    I tried editing both wp-rss.php and wp-rss2.php, removing all blank lines at the beginning of the files to no avail.
    Anyone have an idea how to fix this problem?
    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Kafkaesqui
    Member

    @kafkaesqui

    Something is generating an empty line at the start of every page on your site, which is not a problem with X/HTML documents, but is for syndication feeds, which rely on an XML format that *must* begin with:

    <?xml

    Typically this “something” is a plugin with an errant or extra line, or a badly edited wp-config.php. But in this case it could also be the javascript ad header Go Daddy inserts everywhere on your site.

    johncblacker
    Member

    @johncblacker

    Here is the wp-config.php from the GoDaddy site:
    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘par0634608441567’); // The name of the database
    define(‘DB_USER’, ‘par0634608441567’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘xxxxxxxx’); // …and password
    define(‘DB_HOST’, ‘mysql109.secureserver.net’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>
    I recognize the add stuff at the top of all my pages…how to get rid of them? How to fix this problem?
    Thanks.

    johncblacker
    Member

    @johncblacker

    So, how/where is GoDaddy adding this stuff to my blog?
    Must be some .php code somewhere?

    Kafkaesqui
    Member

    @kafkaesqui

    GoDaddy’s ad stuff would be outside of your control. It’s one of those compromises that comes with free hosting.

    Keeping in mind this *may not be* the cause of the extraneous blank line (though I’d certainly take that bet) and you deal with the fly in the ointment, GoDaddy’s javascript insert will still invalidate your feed. So a full blown bug hunt would hardly be worth the effort.

    johncblacker
    Member

    @johncblacker

    Problem solved…I moved it off of GoDaddy’s free hosting server to another of my websites…I guess when you go “free”, you get more than you bargained for! Anyway, thanks for the information and help Kafkaesqui.

    sms4smile
    Member

    @sms4smile

    My blog is hosted on hostgator, and I am also suffering from the same problem,

    After viewing the source code of several pages on my site, I have observed that that the first line is always blank, however this was not the case about few days back (which means that the theme is fine)

    Even in case of theme problem, may I have a clue where do I start looking from? and start trouble shooting?

    Thanks & Regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] RSS Feed validation failure version 2.0.4 and 2.0.5’ is closed to new replies.