Support » Fixing WordPress » RSS Feed – Turn Off – Access

  • Can someone please pass along some good information & instruction on how I cab disable RSS feed on my website. After checking my host log files someone or something is accessing /feed & /feed/atom and getting our email address(s) and website info. So how can I block this information from appearing as a web page or disable it all together? Please pass along detailed info on what I need to change.

    Thanking you in advance

Viewing 8 replies - 1 through 8 (of 8 total)
  • remove the following lines from the header.php file of the theme you’re using:
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />

    And if you have another link in your theme pointing to your feef, remove it too.

    Just because the URL is not displayed to the user on the HTML page doesn’t mean they can’t click the subscribe button in FF and IE and still get access to your feed.

    How do you TURN OFF the RSS function so that NO ONE can subscribe to your feed… because there IS NO FEED?

    Thanks,
    Dan

    Hopw about deleting the files that make feeds possible????

    wp-feed.php
    wp-rss2.php
    wp-atom.php

    etc…. they’re pretty easy to spot

    i’d like to know how to disable rss feeds too. i’ve tried deleting wp-rss2.php, etc., but you can still access some form of the feed by entering the siteurl/feed. also, when i enter my site url into feedburner, it says that rss 2.0, rss 0.92, and atom feeds were found, even though i’ve deleted the wp files.

    umm, try deleting all three files mentioned by whooami above. That kills my feed. Note, once you do this, you may need to clear your browser cache to see the change (this only applies if you are viewing the feed through a browser).

    stephen,

    actually i deleted those files, cleared my cache, restarted my browser and the feed was visible.

    am 100% certain it wasn’t any sort of cache since even new posts were appearing there.

    i succeeded by creating folders /atom/, /feed/, /rss/, /rss2/ etc. in the base wordpress install folder.

    Okay – for me that seemed to kill the feeds – not sure why yours is more resilient! But as long as you’ve sorted it out now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘RSS Feed – Turn Off – Access’ is closed to new replies.