Support » Fixing WordPress » RSS feed suddenly “not well-formed” any more.

  • Resolved jastram

    (@jastram)


    Hi all,

    I’ve been banging my had against the wall for the last 24 hours, but this must be really stupid.

    tl;dr: My RSS feed broke from one day to the other. the feed validator claims “not well-formed (invalid token)”. I thought I know XML, but I don’t quite understand what’s invalid.

    Details:

    My RSS feed worked for years flawlessly. Not sure when it stopped working, probably within the last 7 days. I did not install any new plugins, but of course I update the site regularly.

    I used the w3c validator, here is the link to the validation results

    The error occurs end the end of the <rss><channel><title> tag:

    This feed does not validate.
    
        line 8, column 45: XML parsing error: <unknown>:8:179: not well-formed (invalid token) [help]
    
             > <channel><title>Systems Engineering Trends</title><link rel="preload" as= ...
                                                         ^

    … and here are the first 8 lines of XML, leading to the issue:

    <?xml version="1.0" encoding="UTF-8"?><rss version="2.0"
    	xmlns:content="http://purl.org/rss/1.0/modules/content/"
    	xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    	xmlns:dc="http://purl.org/dc/elements/1.1/"
    	xmlns:atom="http://www.w3.org/2005/Atom"
    	xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
    	xmlns:slash="http://purl.org/rss/1.0/modules/slash/"
    	>
    
    <channel>
    	<title>Systems Engineering Trends</title>

    Am I crazy, or doesn’t this look totally valid?

    Thanks for your help!

    – Michael

    • This topic was modified 1 year, 9 months ago by jastram.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Thread Starter jastram

    (@jastram)

    Heads-up for anybody reading this: I finally figured out the culprit, it was the Yoast SEO plugin. Uninstalling and reinstalling did the trick, but I am still at a loss why…

Viewing 1 replies (of 1 total)
  • The topic ‘RSS feed suddenly “not well-formed” any more.’ is closed to new replies.