Support » Fixing WordPress » RSS feed stopped working

  • Resolved glenf


    WCUS 2015 Contributor

    Sorry if this is a duplicate, I’ve searched through the FAQs and support section and found many articles that seem very similar to mine. But…I tried their various solutions and haven’t solved my problem yet.

    I created a new blog a few days ago. For the first few days the RSS feed stuff seemed to work fine, but now it gives me that (apparently much-reported!) error message in Safari:

    Safari can’t open the page “feed://�. The error was: “unknown error� (NSURLErrorDomain:-1)

    I am using WordPress 1.5.2 and my hosting provider tells me they are running MySQL 3.23.58 and PHP 4.3.10 on their servers. My pages validate as XHTML and I have tried with no plugins installed. I tried posting new comments and a new post today, clearing my browser cache, all the various ideas I’ve seen posted here, and nothing seems to fix it. A reminder that the RSS feed was working at least for the first day or two my blog was running, then stopped.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mark (podz)


    Support Maven

    Have you tried accessing your feed by other means ?

    I just tested your feed using FeedDemon and it auto-discovered and loaded your feed without problems.

    Could it be Safari ?

    Moderator James Huff


    This may very well be the root of the problem:

    Those two blank lines are probably being caused by plugins. Deactivate all of your active plugins and check the feed’s validation again. If the two blank lines are gone, start activating each plugin one-by-one and check the validation each time. Once you find out which plugin is adding the blank lines, check the plugin’s file for any blank lines at the top or bottom and remove them. That should solve your problem.



    WCUS 2015 Contributor

    Oops, one other piece of info I just discovered, which really helps (why does one not discover these things until after carefully sending the question?). I had tried running it in Firefox but it just forwarded me over to Safari for the feed. But I changed the “feed” to “http” and got this message, which probably tells all (for one of you!)…

    XML Parsing Error: xml processing instruction not at start of external entity
    Line Number 3, Column 1:
    <?xml version="1.0" encoding="UTF-8"?>

    Seems I do have a plugin that is putting whitespace at the start of the file. But if I deactivated my plugins it still remains. (A few minutes later…) Okay, I need to do that and then also clear my cache, then it works. Sorry for the trouble — luckily I also discovered this post that also solves the problem (except for the extra bit of cache clearing again.



    WCUS 2015 Contributor

    Thanks to all, as you see I was solving my own problem as you guys were also. Geez, you folks are fast! Thanks again, now I’m sorted.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘RSS feed stopped working’ is closed to new replies.