Support » Fixing WordPress » RSS Feed stopped updating

  • summeryulenutrition

    (@summeryulenutrition)


    Hello,

    I am having a problem with my RSS feed not updating. This is causing problems because my new posts are not being sent out in my weekly Mailchimp emails, nor are they showing up in the WordPress reader feed and on Bloglovin. (The new posts can still be found through a tag search on the WordPress reader app.)

    I’ve spent hours at this point trying to figure this out and I feel that I am in over my head. Here’s what I know:

    Putting https://summeryule.com/feed/ into my browser shows the updated feed.
    Putting https://summeryule.com/feed/ into https://validator.w3.org/ shows a feed that has not updated since November 23 (this is also when the WordPress reader, Mailchimp, and Bloglovin stopped updating).

    However, all of the following do show an up-to-date feed on https://validator.w3.org/ :
    https://summeryule.com/feed/?t=1
    https://summeryule.com/feed/atom
    https://summeryule.com/feed/rdf
    http://feedcleaner.nick.pro/sanitize?url=https%3A%2F%2Fsummeryule.com%2Ffeed%2F&format=rss

    I have cleared the cache, including the browser cache, and there is no change. I am currently using Fastest Cache with WP Optimize for the image optimization and database features. I have tried completely deactivating and deleting both of these, as well as deactivating JetPack, and it did not fix the issue.

    I am really lost concerning what to do at this point. Here’s what my Jetpack activity log says happened between the last time my feed updated according to w3 and the next time it should have updated:

    Jetpack completed a backup
    I installed the Ad Inserter plug in and then deactivated and deleted it
    Another Jetpack backup
    I modified an html block and a text block on the front page

    None of these things seem significant. Hoping something above provides enough clues that someone can help me out. Apoloqies in advance if I am not posting on the right board.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey @summeryulenutrition,

    It could be that there is some kind of conflict on your site between plugins and/or the theme you are using. This could have happened after an update in WordPress, or possibly on your server (like a PHP version change – which you wouldn’t see from your Jetpack logs).

    Personally, what I would do is to switch on WP-Debug in your wp-config.php file. Then load a few pages on your site (both frontend and backend) and then examine your debug log for some pointers. You may not understand much of what’s in the log, but it will tell you if any plugin or part of your theme is causing any errors. And that would give you a clue.

    The other thing I’d do is to temporarily disable all your plugins and then test again. If the issue goes away, you know it’s to do with a plugin and you can then switch them back on one by one, testing each time to find the one that causes the issue.

    Also, just a hunch, but do you use any security plugin or a service such as Cloudflare? Sometimes they can block things.

    I hope this gives you some ideas. If you’d like more assistance, please reply here and I’ll do my best to help.

    summeryulenutrition

    (@summeryulenutrition)

    Thank you so much for getting back to me quickly. Very long story short, I didn’t come up with much on WP-Debug so I temporarily switched to the twenty-twenty theme and disabled all plugins except Bluehost. It appears that the Really Simple SSL plugin is the source of my troubles. After deactivating it, https://summeryule.com/feed is showing as valid but empty in the RSS feed validator and http://summeryule.com/feed is up-to-date. The missing posts are now showing up on Bloglovin and on the WordPress Reader.

    I am restoring my site and will try to figure out the rest tomorrow. Ideally, I’d like the feeds to function well without compromising security. Any suggestions are appreciated. Thank you again 🙂

    It sounds like you’re on the right path getting to a solution, that’s wonderful 🙂

    You might want to post your findings to the developers of the Really Simple SSL plugin and they might be able to assist more.

    Alternatively, I know they’ve included an option in the settings to disable the plugin while keeping your site on SSL. So that might be an option too. You’d lose automatic URL rewrites of insecure content, but you could fix that separately with a different plugin or a database search and replace.

    Good luck!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.