RSS feed still not working (7 posts)

  1. tbuley
    Posted 9 years ago #

    I've checked most the support posts here, upgraded to the 2600 version of the wp-blog-header.php (http://trac.wordpress.org/file/trunk/wp-blog-header.php?rev=2600) and deleted and reinstalled several times. still, none of my feeds work:


    Instead, I get this message: XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://libertarianconservative.com/blog/wp-rss2.php
    Line Number 1, Column 2: <?xml version="1.0" encoding="UTF-8"?>


  2. Kafkaesqui

    Posted 9 years ago #

    Something, perhaps a plugin, is adding a space before the xml declaration, which is invalidating the file as xml. I'd first suggest turning off what plugins you're running and see if this hits on the problem. Also look at any WP files you may have edited (such as wp-config.php) and make sure they begin with:


    and end with:


    there being no extra spaces or lines before or after these tags.

  3. tbuley
    Posted 9 years ago #

    I disabled all plugins and tried again.. no avail. (They're now reenabled.) Thanks for the help!

  4. tbuley
    Posted 9 years ago #

    Good news: I got it. I went through an deleted white space from several plugins.. I wonder why it still didn't work when I turned them off? Anyways, thanks!

  5. bshirley
    Posted 9 years ago #

    how/where are the plugins/whitespace?
    which files do I need to look in?
    (i'm having the same problem - http://wordpress.org/support/topic/55699 )

  6. meisenstadt
    Posted 9 years ago #

    Cross-correlating/posting a few other threads in case it helps; I note that ALL are left at a dead end HELP!

    Broken RSS feeds and XML errors

    Tags do not update Technorati

    RSS feed still not working

    Yahoo RSS failure

    XML Parsing Error: xml processing instruction not

  7. meisenstadt
    Posted 9 years ago #

    I have a solution that worked for me, primarily involving some single-quote to double-quote conversion in the file wp-rss2.php, for which I have posted the old/new file comparison here on my blog. I am cross-posting this to a total of 5 different threads here on the WordPress support forum, mainly out of a desire to help those whom I know must have also been going crazy with this or similar problems. Many thanks for sticking with it!

Topic Closed

This topic has been closed to new replies.

About this Topic