WordPress.org

Forums

podPress
RSS Feed source issue with podpress_trac (3 posts)

  1. Planetshakers
    Member
    Posted 1 year ago #

    Hi there

    We have an app that pulls the rss feed from our website to our app in order for the podcast to play. It used to work fine however something happened recently that it only plays part of the audio.

    We tested MP3 files directly on our site and found that you have two different sources. One source of the MP3 files work as expected, and another is where we're seeing the problem.

    For example...
    This source works correctly:
    http://www.planetshakers.com/pspodcast/wp-content/uploads/media/pscc02032014_se.mp3

    This one does not (which is currently on the rss feed):
    http://www.planetshakers.com/pspodcast/podpress_trac/play/375/0/pscc02032014_se.mp3

    Unfortunately the RSS feed points to the MP3 files in the "podpress_trac" directory and those are the ones that are causing the problem.

    How can I change the RSS feed to point to the MP3 files in the "wp-content' directory?

    https://wordpress.org/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    You have activated the statistics feature of podPress. This feature masks all mp3 URLs with this URL scheme which have the phrase "podpress_trac". Usually when you click on a link with such a masked URL then podPress will recognize that and point the request to the original URL automatically. That the player stops playing after a while may have something to do with the statistic method you have selected. Which one did select? "Counts Only", "Full" or "Full+"? If you have selected "Full+" then switch to "Full" and the problem should go away.

  3. Planetshakers
    Member
    Posted 1 year ago #

    Thank you for your help.

    I actually have it on "Counts Only". I have change it to "Full" now. Pray that it works.
    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic